Setting default path: log and data doesnt work


(Ammo) #1

Hi,

i am currently in the upgrade process of Elasticsearch 5.6 to version 6.x
Cluster Checkup found some errors. One of them was:

Default path settings are removed
This issue must be resolved to upgrade. Read Documentation

I added these lines in /etc/elasticsearch/elasticsearch.yml:

path.data: /var/lib/elasticsearch
path.logs: /var/log/elasticsearch

But i have still the same error. I restartet elasticsearch and kibana twice and the whole server but still the same error.

Any idea why this is still showing up?

Regards,
Ahmet

EDIT: Do i have to set those paths also in kibana?


(Christian Dahlqvist) #2

It looks like an incorrect file name. elasticserach.yml instead of elasticsearch.yml. Is this a cut and paste error or a typo?


(Ammo) #3

typo. my fault :-S
The file i edited was the correct one :slight_smile:


(Christian Dahlqvist) #4

Can you show us the full error from the logs and your Elasticsearch config?


(Ammo) #7

Hi Christian.
This solved my problem : Upgrade Assistant - Default path settings are removed
Thank you anyway :wink:
Regards,
Ahmet


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.