Setting HEAP SIZE and one node doesn't get it


(Juan) #1

Hi,

I have 4 nodes and I'm setting HEAP SIZE in jvm.options file as follow. The serves have 8GB and I want to setup with 4GB

-Xms4g
-Xmx4g

In three of them is working right but in one node the value is not set as I want and takes 1GB by default.

[2018-02-14T13:34:38,385][INFO ][o.e.n.Node ] [node_3_slave] JVM arguments [-Xms1g, -Xmx1g, -XX:+UseConcMarkSweepGC, -XX:CMSInitiatingOccupancyFraction=75, -XX:+UseCMSInitiatingOccupancyOnly, -XX:+AlwaysPreTouch, -Xss1m, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djna.nosys=true, -XX:-OmitStackTraceInFastThrow, -Dio.netty.noUnsafe=true, -Dio.netty.noKeySetOptimization=true, -Dio.netty.recycler.maxCapacityPerThread=0, -Dlog4j.shutdownHookEnabled=false, -Dlog4j2.disable.jmx=true, -XX:+HeapDumpOnOutOfMemoryError, -Delasticsearch, -Des.path.home=C:\elasticsearch, -Des.path.conf=C:\elasticsearch\config, exit, -Xms1024m, -Xmx1024m, -Xss1024k]

How I can check to solve the problem?

I have also checked in kibana with the following command and this node do not listen the parameter
GET _nodes/stats/jvm

Thanks and BR


(Juan) #2

Solved!

I have removed and installed the elastic service and now is running. It seems the parameters are configured in the service and if I change anything of Jvm I have to reinstall.

Thanks


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.