Setting index.mapper.dynamic was removed after version 6.0.0


we have trouble after elasticsearch 7.0.1 upgrade (from 6.7).
The cluster itself exists since version 5.4 or even earlier always rolling upgrading.

It always complains about:

"Setting index.mapper.dynamic was removed after version 6.0.0"

this does happen it seems on every index create and also breaks kibana (

we tried to remove the settings:

curl -X PUT "" -H 'Content-Type: application/json' -d'

which is acked, but it still doesnt work out to create indexes.

curl -X PUT ""

{"error":{"root_cause":[{"type":"remote_transport_exception","reason":"[search-6][][indices:admin/create]"}],"type":"illegal_argument_exception","reason":"Setting index.mapper.dynamic was removed after version 6.0.0"},"status":400}`

doesnt say anthing about index.mapper.dynamic, also theres nothing in the env for the servers..

please help out asap, we need kibana running in our cluster ! :frowning:

Is it mentioned in an index template? I.e. do you see this setting mentioned anywhere in the output of curl ""?

hey @DavidTurner

thanks for the prompt answer!

We getting closer, yes it is:

curl -s "" | grep mapper
      "index.mapper.dynamic" : "false"
      "index.mapper.dynamic" : "false",
      "index.mapper.dynamic" : "false",

how to get rid of it?

solved it by deleting those templates.

anyways should this not somehow mentioned in the upgrade process or did it miss it? especially the template part was important..

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.