Setting java.library.path or windows authentication


I'm using jdbc and I have the following filled out:

input {
jdbc {
jdbc_driver_library => "the/path/to/sqljdbc42.jar"
jdbc_driver_class => ""
jdbc_connection_string => "jdbc:sqlserver://server:1433;databaseName=theName;integratedSecurity=true"
jdbc_user => ""
jdbc_password => "
statement => "SELECT * FROM [DB].[SCHEMA].[TABLE]"
output {
stdout { }

But when I run logstash it says "WARNING: failed to load the sqljdbc_auth.dll cause : no sqljdbc_auth in java.library.path"

How can I tell logstash where my sqljdbc_auth.dll is? How do I set java.library.path?

I copied sqljdbc_auth.dll to my java home dir lib folder but that didn't work. I also don't like to do it that way. What config setting in logstash an I do to make it know where sqljdbc_auth.dll is?