Setting passwords in elasticsearch cluster

I have a working cluster

"cluster_name" : "elk",
"status" : "green",
"timed_out" : false,
"number_of_nodes" : 3,
"number_of_data_nodes" : 3,
"active_primary_shards" : 3,
"active_shards" : 6,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 0,
"delayed_unassigned_shards" : 0,
"number_of_pending_tasks" : 0,
"number_of_in_flight_fetch" : 0,
"task_max_waiting_in_queue_millis" : 0,
"active_shards_percent_as_number" : 100.0

I want to password Protect so i enabled xpack security

Use a descriptive name for your cluster: elk true true
#discovery.type: single-node

When I go set my passwords I get a cluster error.

./elasticsearch-setup-passwords interactive

Failed to determine the health of the cluster running at http://10.10.10.A:9200
Unexpected response code [503] from calling GET http://10.10.10.A:9200/_cluster/health?pretty
Cause: master_not_discovered_exception

It is recommended that you resolve the issues with your cluster before running elasticsearch-setup-passwords.
It is very likely that the password changes will fail when run against an unhealthy cluster.

Not sure what setting I have wrong.

Please format your code/logs/config using the </> button, or markdown style back ticks. It helps to make things easy to read which helps us help you :slight_smile:

Is that the response from the first part of your post?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.