Setting script.max_compilations_per_minute error

Hey Elastic-Team
im getting following Error when changing the max_compilations_per_minute via Kibana
Following Syntax was used for the chaning the setting

PUT /_cluster/settings
{
    "transient" : {
        "script.max_compilations_per_minute" : 20
    }
}

This is the errormsg i got.

{
"error": {
"root_cause": [
{
"type": "illegal_argument_exception",
"reason": "transient setting [script.max_compilations_per_minute], not recognized"
}
],
"type": "illegal_argument_exception",
"reason": "transient setting [script.max_compilations_per_minute], not recognized"
},
"status": 400
}

Thx for any help

Hi,

What version of Elasticsearch are you using? From 6.0 onwards, this setting is called script.max_compilations_rate, and it takes a value like 75/5m or 20/1m. It's documented here:

https://www.elastic.co/guide/en/elasticsearch/reference/7.3/circuit-breaker.html#script-compilation-circuit-breaker

-William

1 Like

Hey William,

im working on version 7.0.0 and i was looking at following topic

So i just got the wrong setting name.
Thanks for your help !

1 Like