Setting source compression on existing index not working

hi,
i want to enable source compression on an existing test index. but i dont
think my setting is working. can someone confirm -

curl -XPUT 'http://localhost:9200/test/_settings?pretty=true' -d '{"index"
: { "_source" : {"compress" : true } } }'
{
"ok" : true
}

curl -XGET 'http://localhost:9200/test/_settings?pretty=true'
{
"test" : {
"settings" : {
"index.number_of_shards" : "5",
"index.number_of_replicas" : "1",
"index.refresh_interval" : "60000"
}
}
}

--

Hiya

i want to enable source compression on an existing test index. but i
dont think my setting is working. can someone confirm -

curl -XPUT 'http://localhost:9200/test/_settings?pretty=true' -d
'{"index" : { "_source" : {"compress" : true } } }'
{
"ok" : true
}

It is a mapping, not an index setting, and a type is required:

curl -XPUT 'http://127.0.0.1:9200/test/my_type/_mapping?pretty=1' -d '
{
"my_type" : {
"_source" : {
"compress" : 1
}
}
}
'

--

thanks, that worked!
also, how long does one have to wait for the compression to start/end? i
waited for 6hrs for 1 index and no change in size. running optimize also
didnt make a difference. running optimize with max_num_segments=true
decreased the size by a great amount.

thanks

On Tue, Nov 27, 2012 at 12:55 AM, Clinton Gormley clint@traveljury.comwrote:

Hiya

i want to enable source compression on an existing test index. but i
dont think my setting is working. can someone confirm -

curl -XPUT 'http://localhost:9200/test/_settings?pretty=true' -d
'{"index" : { "_source" : {"compress" : true } } }'
{
"ok" : true
}

It is a mapping, not an index setting, and a type is required:

curl -XPUT 'http://127.0.0.1:9200/test/my_type/_mapping?pretty=1' -d '
{
"my_type" : {
"_source" : {
"compress" : 1
}
}
}
'

--

--

Hello,

As far as I know, only the source of new documents will be compressed, from
the moment you change your mapping.

Best regards,
Radu

http://sematext.com/ -- ElasticSearch -- Solr -- Lucene

On Thu, Nov 29, 2012 at 9:12 AM, T Vinod Gupta tvinod@readypulse.comwrote:

thanks, that worked!
also, how long does one have to wait for the compression to start/end? i
waited for 6hrs for 1 index and no change in size. running optimize also
didnt make a difference. running optimize with max_num_segments=true
decreased the size by a great amount.

thanks

On Tue, Nov 27, 2012 at 12:55 AM, Clinton Gormley clint@traveljury.comwrote:

Hiya

i want to enable source compression on an existing test index. but i
dont think my setting is working. can someone confirm -

curl -XPUT 'http://localhost:9200/test/_settings?pretty=true' -d
'{"index" : { "_source" : {"compress" : true } } }'
{
"ok" : true
}

It is a mapping, not an index setting, and a type is required:

curl -XPUT 'http://127.0.0.1:9200/test/my_type/_mapping?pretty=1' -d '
{
"my_type" : {
"_source" : {
"compress" : 1
}
}
}
'

--

--

--