Shard query cache not working for aggregates with simple date range filter

I'm using Elasticsearch 1.4.2 and was excited about the new shard query
cache
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/index-modules-shard-query-cache.html,
but I am surprised this simple terms aggregate doesn't seem to show up in
the cache if I have a date range filter:
https://gist.github.com/nezda/c65dd66785d5f1e4dbd4 -- I'm not referencing
now or anything, so this seems like a bug to me.

Please advise,

  • Luke

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/fc9298f9-cb10-4698-a8f5-09b4d7e19713%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Answering myself: this was reported as a bug several weeks
later https://github.com/elasticsearch/elasticsearch/issues/9225 and the
fix was just released
via https://github.com/elasticsearch/elasticsearch/pull/9269 in 1.4.3. Do
es devs read this list? Is this the wrong venue for this kind of feedback?
I had a gist and everything.

On Friday, December 19, 2014 at 12:49:27 PM UTC-6, Luke Nezda wrote:

I'm using Elasticsearch 1.4.2 and was excited about the new shard query
cache
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/index-modules-shard-query-cache.html,
but I am surprised this simple terms aggregate doesn't seem to show up in
the cache if I have a date range filter:
https://gist.github.com/nezda/c65dd66785d5f1e4dbd4 -- I'm not referencing
now or anything, so this seems like a bug to me.

Please advise,

  • Luke

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2c926e1d-b6de-4929-84ab-3c0f5f61b7f9%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Luke - I've been having this same problem as you originally posted. I just
updated to ElasticSearch 1.4.3 and haven't seen any change of behavior when
using a date range. In fact, it looks like the Gist you posted is still
failing as it was for ES 1.4.2. Have you seen any changes since upgrading
to 1.4.3?

On Tuesday, February 17, 2015 at 11:41:22 AM UTC-5, Luke Nezda wrote:

Answering myself: this was reported as a bug several weeks later
https://github.com/elasticsearch/elasticsearch/issues/9225 and the fix
was just released via
https://github.com/elasticsearch/elasticsearch/pull/9269 in 1.4.3. Do es
devs read this list? Is this the wrong venue for this kind of feedback? I
had a gist and everything.

On Friday, December 19, 2014 at 12:49:27 PM UTC-6, Luke Nezda wrote:

I'm using Elasticsearch 1.4.2 and was excited about the new shard query
cache
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/index-modules-shard-query-cache.html,
but I am surprised this simple terms aggregate doesn't seem to show up in
the cache if I have a date range filter:
https://gist.github.com/nezda/c65dd66785d5f1e4dbd4 -- I'm not
referencing now or anything, so this seems like a bug to me.

Please advise,

  • Luke

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e64008eb-1ff6-4653-9111-8669c1cf698f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Jared -

Silly me for assuming... No, I haven't actually tested with 1.4.3, it just
sounded the same. Did you try testing with @ppf2's
gist https://gist.github.com/ppf2/bfa38b8284e09c0740ad from
https://github.com/elasticsearch/elasticsearch/issues/9225 - it would be
particularly weird & disappointing if that was still broken too, but I
suppose mine could be different issue. I'm happy to hear something on
this thread!

On Tuesday, February 17, 2015 at 12:57:21 PM UTC-6, Jared P wrote:

Luke - I've been having this same problem as you originally posted. I
just updated to ElasticSearch 1.4.3 and haven't seen any change of behavior
when using a date range. In fact, it looks like the Gist you posted is
still failing as it was for ES 1.4.2. Have you seen any changes since
upgrading to 1.4.3?

On Tuesday, February 17, 2015 at 11:41:22 AM UTC-5, Luke Nezda wrote:

Answering myself: this was reported as a bug several weeks later
https://github.com/elasticsearch/elasticsearch/issues/9225 and the fix
was just released via
https://github.com/elasticsearch/elasticsearch/pull/9269 in 1.4.3. Do
es devs read this list? Is this the wrong venue for this kind of feedback?
I had a gist and everything.

On Friday, December 19, 2014 at 12:49:27 PM UTC-6, Luke Nezda wrote:

I'm using Elasticsearch 1.4.2 and was excited about the new shard query
cache
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/index-modules-shard-query-cache.html,
but I am surprised this simple terms aggregate doesn't seem to show up in
the cache if I have a date range filter:
https://gist.github.com/nezda/c65dd66785d5f1e4dbd4 -- I'm not
referencing now or anything, so this seems like a bug to me.

Please advise,

  • Luke

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/aae6efaf-587f-4596-a6ff-48b48b1fe1e2%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Also glad to hear someone else is having this problem. I was also really
excited that they introduced this feature, I've just been having a really
difficult time getting it to work.

So I just updated your script with the data that @ppf2 had in his Gist:
http://pastebin.com/akJG6JQ1
Here's the results: http://pastebin.com/RVDLAbMW

I'm just at the point where I'm not sure if I'm doing something wrong, or
if the bug was never successfully fixed.

On Tuesday, February 17, 2015 at 2:36:35 PM UTC-5, Luke Nezda wrote:

Jared -

Silly me for assuming... No, I haven't actually tested with 1.4.3, it just
sounded the same. Did you try testing with @ppf2's gist
https://gist.github.com/ppf2/bfa38b8284e09c0740ad from
https://github.com/elasticsearch/elasticsearch/issues/9225 - it would be
particularly weird & disappointing if that was still broken too, but I
suppose mine could be different issue. I'm happy to hear something on
this thread!

On Tuesday, February 17, 2015 at 12:57:21 PM UTC-6, Jared P wrote:

Luke - I've been having this same problem as you originally posted. I
just updated to ElasticSearch 1.4.3 and haven't seen any change of behavior
when using a date range. In fact, it looks like the Gist you posted is
still failing as it was for ES 1.4.2. Have you seen any changes since
upgrading to 1.4.3?

On Tuesday, February 17, 2015 at 11:41:22 AM UTC-5, Luke Nezda wrote:

Answering myself: this was reported as a bug several weeks later
https://github.com/elasticsearch/elasticsearch/issues/9225 and the fix
was just released via
https://github.com/elasticsearch/elasticsearch/pull/9269 in 1.4.3. Do
es devs read this list? Is this the wrong venue for this kind of feedback?
I had a gist and everything.

On Friday, December 19, 2014 at 12:49:27 PM UTC-6, Luke Nezda wrote:

I'm using Elasticsearch 1.4.2 and was excited about the new shard
query cache
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/index-modules-shard-query-cache.html,
but I am surprised this simple terms aggregate doesn't seem to show up in
the cache if I have a date range filter:
https://gist.github.com/nezda/c65dd66785d5f1e4dbd4 -- I'm not
referencing now or anything, so this seems like a bug to me.

Please advise,

  • Luke

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3cbd2031-0543-47c1-8449-34c94f916017%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

https://github.com/elasticsearch/elasticsearch/issues/9225 was reopened - apparently fix was lost in merge conflicts and seems there was no automatic test added to catch it.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/976e7f0a-4062-48b9-9f4b-ce0d3f70df8d%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.