[Shard Unassigned] Solutions to reassigned the shard


(AlexK) #1

Hi,

I am using ElasticSearch 1.2.0.

I have a question about the solution to solve the "Shard unassigned"
problem.

Here my setup, pretty simple:
1 NODE - 2 SHARDS / index - NO REPLICA

The situation is the following:

  • I manually moved all the content of /var/data/elasticsearch to another
    location for backup need;
    So I am able to start with a fresh cluster.
  • I restarted the service and everything was going fine until I realised
    that all my Kibana dashboards were not available on the newly live
    cluster.
    I understood it was because of the previous move of the files, so I
    simply moved the* kibana-int* index directory from the backup dir back to
    /var/data/elasticsearch

If it was so simple...:slight_smile:
The new cluster showed the old kibana-int index as unassigned despite
restart of the service.

Questions:

  • How the new cluster can unassigned this index (does it see that it does
    not created this index itself based on timestamp or other, and therefore
    decide to not take it...) ?
  • How can I assign this index ? The only solution I know is to start
    another node (so a 2 nodes cluster) hoping that the second node will take
    the* kibana-int *and then move this index onto the first node.

Thanks a lot for sharing your experience on this matters, I am sure it will
help other.

Best Regards,
Alex

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2fce0328-56f2-4a6c-9343-c4808e983549%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Mark Walkom) #2

It's probably because the cluster state doesn't know about the index even
though it can see it on the filesystem.
I don't know if you can recover this, but there might be a way someone can
suggest.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 8 August 2014 23:17, AlexK alexandre.kapell@gmail.com wrote:

Hi,

I am using ElasticSearch 1.2.0.

I have a question about the solution to solve the "Shard unassigned"
problem.

Here my setup, pretty simple:
1 NODE - 2 SHARDS / index - NO REPLICA

The situation is the following:

  • I manually moved all the content of /var/data/elasticsearch to
    another location for backup need;
    So I am able to start with a fresh cluster.
  • I restarted the service and everything was going fine until I realised
    that all my Kibana dashboards were not available on the newly live
    cluster.
    I understood it was because of the previous move of the files, so I
    simply moved the* kibana-int* index directory from the backup dir back to
    /var/data/elasticsearch

If it was so simple...:slight_smile:
The new cluster showed the old kibana-int index as unassigned despite
restart of the service.

Questions:

  • How the new cluster can unassigned this index (does it see that it does
    not created this index itself based on timestamp or other, and therefore
    decide to not take it...) ?
  • How can I assign this index ? The only solution I know is to start
    another node (so a 2 nodes cluster) hoping that the second node will take
    the* kibana-int *and then move this index onto the first node.

Thanks a lot for sharing your experience on this matters, I am sure it
will help other.

Best Regards,
Alex

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/2fce0328-56f2-4a6c-9343-c4808e983549%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/2fce0328-56f2-4a6c-9343-c4808e983549%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624YT8Zz8o901z6RMFdR_mMYwvOhc6FSkTM%2BghLJ2zJa0_w%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(AlexK) #3

Yeah, I agree.
It is kind of frustrating, as I know it is on the right place but ES gives
me still YELLOW !
I wish It was only a matter of modifying a single file in the index
directory.

Can someone share its experience on the matter ?

Thanks,
Alex.

2014-08-09 2:23 GMT+02:00 Mark Walkom markw@campaignmonitor.com:

It's probably because the cluster state doesn't know about the index even
though it can see it on the filesystem.
I don't know if you can recover this, but there might be a way someone can
suggest.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 8 August 2014 23:17, AlexK alexandre.kapell@gmail.com wrote:

Hi,

I am using ElasticSearch 1.2.0.

I have a question about the solution to solve the "Shard unassigned"
problem.

Here my setup, pretty simple:
1 NODE - 2 SHARDS / index - NO REPLICA

The situation is the following:

  • I manually moved all the content of /var/data/elasticsearch to
    another location for backup need;
    So I am able to start with a fresh cluster.
  • I restarted the service and everything was going fine until I realised
    that all my Kibana dashboards were not available on the newly live
    cluster.
    I understood it was because of the previous move of the files, so I
    simply moved the* kibana-int* index directory from the backup dir back
    to /var/data/elasticsearch

If it was so simple...:slight_smile:
The new cluster showed the old kibana-int index as unassigned despite
restart of the service.

Questions:

  • How the new cluster can unassigned this index (does it see that it
    does not created this index itself based on timestamp or other, and
    therefore decide to not take it...) ?
  • How can I assign this index ? The only solution I know is to start
    another node (so a 2 nodes cluster) hoping that the second node will take
    the* kibana-int *and then move this index onto the first node.

Thanks a lot for sharing your experience on this matters, I am sure it
will help other.

Best Regards,
Alex

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/2fce0328-56f2-4a6c-9343-c4808e983549%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/2fce0328-56f2-4a6c-9343-c4808e983549%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/7elBE7EUYmI/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAEM624YT8Zz8o901z6RMFdR_mMYwvOhc6FSkTM%2BghLJ2zJa0_w%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAEM624YT8Zz8o901z6RMFdR_mMYwvOhc6FSkTM%2BghLJ2zJa0_w%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
Alexandre KAPELL
Email : alexandre.kapell@gmail.com
Tél : (+33) 06.37.67.04.03

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGYBOpnDf%2BF0jzTTtjbo9_xaQ5NKHFku%3DOQvpJ30NPDUBzb1Dw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(AlexK) #4

Hi,

Does anyone has a definitive answer to this problem ?

Alex.

Le lundi 11 août 2014 19:11:02 UTC+2, AlexK a écrit :

Yeah, I agree.
It is kind of frustrating, as I know it is on the right place but ES
gives me still YELLOW !
I wish It was only a matter of modifying a single file in the index
directory.

Can someone share its experience on the matter ?

Thanks,
Alex.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/99c81714-1815-408c-afc5-094eec5c710a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #5