Shingle Token Filter min_shingle_size (0.19.9)


(Geoff Stockham) #1

Hi,

I've just got around to upgrading from 0.19.4 to 0.19.9, and now indexing
gives me the error "IllegalArgumentException[Min shingle size must be <=
max shingle size]"

I've had the max_shingle_size to 5 in the previous versions with no
problems. I've tried adding the min_shingle_size as well but still get the
error. The only thing that works is removing all settings and reverting to
the defaults.

For info, I'm using PlainElastic.Net to create the settings, but I can see
them set in the index metadata so I don't think that's where the issue is.

Any ideas? Has something changed in the latest version?

Thanks

Geoff

--


(Geoff Stockham) #2

Sorry, to answer my own question, this has changed:

"Fix reversed ShingleFilter constructor arguments"

If I change my parameter to "min_shingle_size" instead of
"max_shingle_size" I get the behaviour I had before.

I'll create a github issue.

Geoff

On Friday, 21 September 2012 16:08:17 UTC+1, Geoff Stockham wrote:

Hi,

I've just got around to upgrading from 0.19.4 to 0.19.9, and now indexing
gives me the error "IllegalArgumentException[Min shingle size must be <=
max shingle size]"

I've had the max_shingle_size to 5 in the previous versions with no
problems. I've tried adding the min_shingle_size as well but still get the
error. The only thing that works is removing all settings and reverting to
the defaults.

For info, I'm using PlainElastic.Net to create the settings, but I can see
them set in the index metadata so I don't think that's where the issue is.

Any ideas? Has something changed in the latest version?

Thanks

Geoff

--


(system) #3