Shingles in Elasticsearch, why does this example with custom analyzer fail?


(JEB) #1

Hi Guys,

I've been struggling with this for a couple of days.
I defined a custom search and index analyzer on a field and can't get it to
work.

There is a full curl recreation available at stackoverflow:

Can anyone help me with this?

Thanks!!
Jeb

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e49c62d0-5851-48d2-8cb4-d32b17853750%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #2

Term query is not analyzed so your query is directly compared to what you have indexed.

Which is the output of:

curl 'localhost:9200/test_shingling/_analyze?pretty=1&analyzer=ShingleAnalyzer

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 28 avr. 2014 à 07:49, JEB jbonerz@googlemail.com a écrit :

Hi Guys,

I've been struggling with this for a couple of days.
I defined a custom search and index analyzer on a field and can't get it to work.

There is a full curl recreation available at stackoverflow:

Can anyone help me with this?

Thanks!!
Jeb

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e49c62d0-5851-48d2-8cb4-d32b17853750%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/87D5D19D-2CCC-4DEB-AD33-6CEDB0DE7DD5%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.


(JEB) #3

I also tried this previously without success.

{ "query": { "query_string": { "default_operator": "and" ,"default_field":
"Title", "query": "solar panel" } } }

{ "query": { "query_string": { "default_field": "Title", "query": "solar
panel" } } }

Can you guide me into the right direction?

Am Montag, 28. April 2014 08:11:15 UTC+2 schrieb David Pilato:

Term query is not analyzed so your query is directly compared to what you
have indexed.

Which is the output of:

curl 'localhost:9200/test_shingling/_analyze?pretty=1&analyzer=ShingleAnalyzer

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 28 avr. 2014 à 07:49, JEB <jbo...@googlemail.com <javascript:>> a
écrit :

Hi Guys,

I've been struggling with this for a couple of days.
I defined a custom search and index analyzer on a field and can't get it
to work.

There is a full curl recreation available at stackoverflow:

http://stackoverflow.com/questions/23295896/shingles-in-elasticsearch-why-does-this-example-with-custom-analyzer-fail

Can anyone help me with this?

Thanks!!
Jeb

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/e49c62d0-5851-48d2-8cb4-d32b17853750%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/e49c62d0-5851-48d2-8cb4-d32b17853750%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2125f5fb-32cf-4104-b070-9320dc51db7a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #4

Did you try a Match query (instead of Term)?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 28 avr. 2014 à 08:27, JEB jbonerz@googlemail.com a écrit :

I also tried this previously without success.

{ "query": { "query_string": { "default_operator": "and" ,"default_field": "Title", "query": "solar panel" } } }

{ "query": { "query_string": { "default_field": "Title", "query": "solar panel" } } }

Can you guide me into the right direction?

Am Montag, 28. April 2014 08:11:15 UTC+2 schrieb David Pilato:

Term query is not analyzed so your query is directly compared to what you have indexed.

Which is the output of:

curl 'localhost:9200/test_shingling/_analyze?pretty=1&analyzer=ShingleAnalyzer

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 28 avr. 2014 à 07:49, JEB jbo...@googlemail.com a écrit :

Hi Guys,

I've been struggling with this for a couple of days.
I defined a custom search and index analyzer on a field and can't get it to work.

There is a full curl recreation available at stackoverflow:
http://stackoverflow.com/questions/23295896/shingles-in-elasticsearch-why-does-this-example-with-custom-analyzer-fail

Can anyone help me with this?

Thanks!!
Jeb

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e49c62d0-5851-48d2-8cb4-d32b17853750%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2125f5fb-32cf-4104-b070-9320dc51db7a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/1A5C4279-34C5-4B30-B439-8DBF690A2630%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.


(system) #5