Skipping rollover option

I have enabled skipping rollover option while using index lifyce cycle policy . But ILM still tries to perform rollover.

https://www.elastic.co/guide/en/elasticsearch/reference/current/skipping-rollover.html

below is the error we see

illegal_argument_exception: setting [index.lifecycle.rollover_alias] for index [oracle-alert-fields-2019.47] is empty or not defined

we are doing index rollover every day at logstash. we are trying to use lifecycle policy to delete indices whey they are x number of days old.

below are index settings

{
"index.query.default_field": [
"*"
],
"index.refresh_interval": "1s",
"index.write.wait_for_active_shards": "1",
"index.lifecycle.name": "cdldev_policy",
"index.lifecycle.indexing_complete": "true",
"index.blocks.read_only_allow_delete": "false",
"index.priority": "100",
"index.number_of_replicas": "1"
}

is anyone faced similar issue? are there any alternatives ways to fix roll over error while using iLM?

Hi
@alisongoryachev or @cufflinks , can you please help here?

sorry to tag , trying to get somehelp on this issue.

trying to understand why skipping rollover option is not functioning on the ILM policy

Thanks

i see a related post on this , but dont see a solution on this

Tagging @oysteila if you have got any solution here.

Thanks your time.