Snapshot & Minio

Hi! Is it possible to change the S3 URL to be something custom? Like a Minio server, for example.

I tried setting s3.client.default.endpoint

to our internal Minio server yet ES is still trying to hit AWS.

I'm POST'ing this to _snapshot/minio:

 "type": "s3",
 "settings": {
  "bucket": "elasticsearch",
  "compress": "true",
  "protocol": "http"

I tried adding the endpoint as well to the data but ES is still trying to access AWS S3 and nothing custom.

Any clues would be greatly appreciated.

Thank you!

AFAIK we only officially support AWS endpoint for the repository-s3 plugin. Anyway, could you change the logs for org.elasticsearch.repositories.s3 and packages?

PUT /_cluster/settings
  "transient": {
    "": "trace",
    "": "trace"

And try again and paste the logs here or on

Gotcha. Here's the logs:

Apparently the endpoint is not set:

[2018-03-22T17:40:19,280][DEBUG][o.e.r.s.InternalAwsS3Service] [test] creating S3 client with client_name [default], endpoint []

Can you share your elasticsearch.yml file?
Did you restart the node after adding s3.client.default.endpoint?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.