[SOLVED]After upgrade to 7.7.0 in a cluster of 3 nodes. - failed to retrieve password hash for reserved user [elastic]


We have a small cluster that we upgraded from 7.6.2 to 7.7.0 with .deb's.
Everything went fine with the upgrade.
Plugins were updated and all was rainbows and ponies :slight_smile:

Then when I tried to update the plugins in kibana things were looking interesting.

I can not connect to the elasticsearch API with the set credentials.
[2020-05-28T10:22:16,825][INFO ][o.e.x.s.a.AuthenticationService] [log01] Authentication of [elastic] was terminated by realm [reserved] - failed to authenticate user [elastic]
[2020-05-28T10:22:16,871][ERROR][o.e.x.s.a.e.ReservedRealm] [log01] failed to retrieve password hash for reserved user [elastic]
org.elasticsearch.action.UnavailableShardsException: at least one primary shard for the index [.security-7] is unavailable

Any Ideas?

Regards Falk

This is now solved.
And I wish I could say what we did...
My working assumption is that the cluster was in a failed mode so the master node could not read .security index..
After a restart of the whole cluster things are getting back to some kind of likenesses of working :slight_smile:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.