[Solved] Elastic shutdowns whenever he wants


(elaelaela) #1

Hi! First of all I never used elastic search before, only mysql, but for searching 1m records I decided to use elastic.

I'm using elastic php library to insert and get records and use only autosuggest feature. On type get records.

Main problem - elastic shut downs whenever he wants. I have 4GB vps with mysql 2000Mb (50%) and elastic with default configs (I guess it uses 1GB config). On the casual check of processes mysql uses 51-52% nginx php processes 1-10%, so I dunno why elastic always shutdowns.

in the logs (/var/log/elasticsearch) on the last file 2018-02-28
I have errors

com.fasterxml.jackson.core.JsonParseException: Unexpected character ('B' (code 66)): was expecting comma to separate Object entries

and a lot of

com.fasterxml.jackson.core.JsonParseException: Unexpected character ('Ð' (code 208)): was expecting comma to separate Object entries

Here full logs
2018-02-24-1.log https://pastebin.com/7xhr2bAZ
2018-02-25-1.log https://pastebin.com/7Yi87jA4 [maybe has needed info]
2018-02-26-1.log https://pastebin.com/x6Fjg8jx
2018-02-27-1.log https://pastebin.com/PHNsURiT
gc.log.0.current https://pastebin.com/KHnEZHtf
myapp-application.log https://pastebin.com/arwL0ujB

I guess it is maybe some ram overage, so my second question how to set elastic to use 0.5GB ram, not 1gb


(David Pilato) #2

How did you install it?
How do you start it?


(elaelaela) #3

solved issue by lowering jvm ram usage to 512m


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.