[Solved] Elasticsearch not accessible over internet through ip addresss


We are facing issues while accessing elasticsearch over ip address on internet in AWS Windows environment.

Could you please help me resolve this issue?

I have tried various options of modifying network.host parameter and network.bind_host paramter, without any luck.

Would be really grateful if you can provide with the valid elasticsearch.yml file.

Request your kind help!


You have to set network.host to the private IP or public if you need to access it from outside of AWS I guess.
Check that your security group allows the 9200 traffic from your IP address to this machine.

Be careful with this, without proper access control you may end up with dataloss or exposure.


Thanks for your replies!!!

Tried all option in elasticsearch conf file by setting both private and public address on AWS system, without any luck.

Would like to consider following points as well:

--> When I set the Elasticsearch in local desktop, I am able to access the elasticsearch over ip address.
--> I am able to access Kibana hosted in AWS, using the private ip address of the machine. (which implies 560X port is opened to internet)
--> Even if I configure Elasticsearch to run in one of the ports of Kibana (say 5605) in AWS, it is not accessible over ip address.

Could you please help me with the inputs on how can I solve this issue?


Hi All,

This issue has got resolved finally!!!

Following are the additional configurations that required to be done on AWS side for exposing the port over internet:

--> In AWS Console, configured the inbound ports with the ElasticSearch port.
-- In Windows Firewall of the machine, created an inbound rule for the ElasticSearch port to make it open.

Thanks a lot for your support!!!