[SOLVED] - Enabling _size

I would like to enable _size field on all my indexes (I know I need that data reindexed).
But after installing mapper-size plugin and inserting new template :

	"template" : "logs*",
	"settings" : {
		"index.analysis.analyzer.default.type": "simple",
		"index.cache.field.type": "soft",
		"index.codec": "best_compression",
		"index.merge.policy.max_merged_segment": "20gb",
		"index.query.default_field": "message",
		"index.refresh_interval": "10s",
		"index.store.compress.stored": true,
		"index.store.compress.tv": true,
		"index.term_index_divisor": 1,
		"index.term_index_interval": 128,
		"number_of_replicas": 1,
		"number_of_shards": 5
	"mappings" : {
		"_default_" : {
			"_all" : {
				"enabled" : false,
				"omit_norms" : true
			"_size" : {
				"enabled" : true
			"dynamic_templates" : [

[... shortened I think this is all needed for this question]`

I am still not getting _size field in new indexes...
Any hint would be appreciated

Take a look at https://www.elastic.co/guide/en/elasticsearch/reference/2.3/breaking_20_removed_features.html#_literal__size_literal_is_now_a_plugin

but I did mention that "But after installing mapper-size plugin ", so this link is kind of useless for me (I have seen it before.
So my question is again same how to get _size field working?
To make it clear:

  • plugin is installed on all nodes
  • ES version is 2.3.1
  • size is enabled in my template (hope it is on right place)

But still no _size field available (in new indexes)
Cheers AM

PS: please don take me as a rude person, that is not my intention.

Personally I'd fiddle with it outside of the template first and then see about getting it into the template - you know, work the problem in smaller and smaller chunks and then add. Eventually you'll find something you were doing wrong or you'll end up with great bug recreation steps.

This is the way the size mapper is tested so it might be the best place to start. Like, translate that to JSON and try it locally. If that doesn't work then you've got a problem on the plugin installation end. Maybe also one about error reporting. If it does work, keep trying things that are more and more like your use case.

Sorry this isn't just working. Good luck. Please let us know what it turns out to be.

Ok thank you for your help,
my problem was that I didn't have _size included in my kibana config.
Sorry to be so stupid.
Have nice day AM

Sorry, misread that originally!