[Solved] Error Building RPM Against 2.0 Branch


(The Dude) #1

I am not very familiar with maven so any help is appreciated. I am seeing the following when I run the command

mvn package rpm:rpm -DskipTests -Dvalidate.skip

org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.codehaus.mojo:rpm-maven-plugin:2.1.3:rpm (default-cli) on project dev-tools: The parameters 'group' for goal org.codehaus.mojo:rpm-maven-plugin:2.1.3:rpm are missing or invalid

I am not entirely certain what I need to change about the pom file under dev-tools to get this to work. Any help is appreciated.


(David Pilato) #2

This is strange because group is actually set here.

Try to build it from the project root dir using mvn clean install -DskipTests and see how it goes...


(The Dude) #3

Well this reveals how little I know about java and maven.

Building from the root of the project fails, but if I go into the distribution/rpm directory and issue the command

mvn package rpm:rpm -DskipTests

then it succeeds. Briefly, is that expected? Is there any pattern to this? It feels like I should be able to issue any command from the root, but this looks otherwise. Any explanations are appreciated.


(David Pilato) #4

Did you run the exact same command from the root or mvn install?

mvn install should work from the root.

Also prefer mvn install (install is a lifecycle phase) than mvn rpm:rpm (rpm:rpm is a plugin name:goal).


(The Dude) #5

That does in fact build it. Thanks for your time and patience.


(system) #6