[Solved] Installing filebeat-6.2.2-amd64.deb, no modules.d


(Eric) #1

I'm a little confused. I installed filebeat-6.2.2-amd64.deb, however, there is nothing in /etc/filebeat, and none of the modules (i.e. system.yml, system.yml.disabled) can be found anywhere in /etc or /usr

They exist in filebeat-6.2.2-linux-x86_64.tar.gz, however


(Carlos Pérez Aradros) #2

Hi @naisanza,

Can you please report the output of these commands?

dpkg -l filebeat

dpkg -L filebeat

Best regards


(Eric) #3
root@bigma:# dpkg -i filebeat-6.2.2-amd64.deb
Selecting previously unselected package filebeat.
(Reading database ... 179870 files and directories currently installed.)
Preparing to unpack .../beats/filebeat-6.2.2-amd64.deb ...
Unpacking filebeat (6.2.2) ...
Setting up filebeat (6.2.2) ...
Processing triggers for systemd (229-4ubuntu21.2) ...
Processing triggers for ureadahead (0.100.0-19) ...
root@bigma:~# find /etc/filebeat
/etc/filebeat
/etc/filebeat/modules.d
root@bigma:~#

dpkg -l filebeat

root@bigma:/etc/filebeat# dpkg -l filebeat
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name               Version        Architecture   Description
+++-==================-==============-==============-=========================================
ii  filebeat           6.2.2          amd64          Filebeat sends log files to Logstash or d

dpkg -L filebeat:
https://pastebin.com/CCgFck6r


(Carlos Pérez Aradros) #4

It sounds like the package include these files but they were deleted? I recommend purging it (apt-get remove --purge filebeat) and install it again.

Best regards


(Eric) #5

That fixed it! Thanks!


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.