Solved: Rebuilt node, logs say waiting for local exporter

Hey folks,

I had to rebuild one of my nodes so I did what I needed to take it offline. After rejoining, the logs are showing:
[2017-07-10T09:35:46,658][INFO ][o.e.x.m.e.l.LocalExporter] waiting for elected master node [{hostname}{9r5z4QWnSQ2MI8Sg4afSqA}{HssFZKyBR82Tub_bx8IgOA}{x.x.x.x}{x.x.x.x:9300}{ml.enabled=true}] to setup local exporter [default_local] (does it have x-pack installed?)

I have x-pack installed on all nodes so not sure how to fix. Also, in Kibana monitoring, it says I have 6 nodes but only displays 5. The missing node is the one I rebuilt. Being new to this, I am not sure what to be checking.


Solved. Turns out when I rebuilt the node, it had installed 5.5 where the other nodes were all 5.4. I have updated all nodes to 5.5 and it is working again.

1 Like

This one also caught me out!

nice catch, spent the last 30 mins trying all sorts of tricks to resolve that error! :angry:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.