Something is wrong with my confifg file - Oracle DB Connection

Hello,

I try to connect Oracle DB. I am using config file for that reason. My config is

input {
jdbc {
    jdbc_connection_string => "jdbc:oracle:thin:@//00.000.00.0:0000/PRELIVE1"
    jdbc_user => "*****"
    jdbc_password => "****"
    jdbc_driver_library => "C:\Users\Hakansu\Downloads\ojdbc6.jar"
    jdbc_driver_class => "Java::oracle.jdbc.driver.OracleDriver"
    statement => "SELECT * from Sales"
}
}
output {
    elasticsearch {
        protocol => http
        index => "contacts"
        document_type => "contact"
        document_id => "%{uid}"
        host => "my_first_node"
    }
}

When I run this file I get

[2019-05-23T15:20:26,312][WARN ][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified
[2019-05-23T15:20:26,327][INFO ][logstash.runner ] Starting Logstash {"logstash.version"=>"7.0.1"}
[2019-05-23T15:20:31,471][ERROR][logstash.outputs.elasticsearch] Unknown setting 'host' for elasticsearch
[2019-05-23T15:20:31,471][ERROR][logstash.outputs.elasticsearch] Unknown setting 'protocol' for elasticsearch
[2019-05-23T15:20:31,487][ERROR][logstash.agent ] Failed to execute action {:action=>LogStash::PipelineAction::Create/pipeline_id:main, :exception=>"LogStash::ConfigurationError", :message=>"Something is wrong with your configuration.", :backtrace=>["C:/Users/Hakansu/Desktop/logstash-7.0.1/logstash-7.0.1/logstash-core/lib/logstash/config/mixin.rb:86:in config_init'", "C:/Users/Hakansu/Desktop/logstash-7.0.1/logstash-7.0.1/logstash-core/lib/logstash/outputs/base.rb:60:ininitialize'", "org/logstash/config/ir/compiler/OutputStrategyExt.java:232:in initialize'", "org/logstash/config/ir/compiler/OutputDelegatorExt.java:48:ininitialize'", "org/logstash/config/ir/compiler/OutputDelegatorExt.java:30:in initialize'", "org/logstash/plugins/PluginFactoryExt.java:239:inplugin'", "org/logstash/plugins/PluginFactoryExt.java:137:in buildOutput'", "org/logstash/execution/JavaBasePipelineExt.java:50:ininitialize'", "C:/Users/Hakansu/Desktop/logstash-7.0.1/logstash-7.0.1/logstash-core/lib/logstash/java_pipeline.rb:23:in initialize'", "C:/Users/Hakansu/Desktop/logstash-7.0.1/logstash-7.0.1/logstash-core/lib/logstash/pipeline_action/create.rb:36:inexecute'", "C:/Users/Hakansu/Desktop/logstash-7.0.1/logstash-7.0.1/logstash-core/lib/logstash/agent.rb:325:in `block in converge_state'"]}
[2019-05-23T15:20:31,802][INFO ][logstash.agent ] Successfully started Logstash API endpoint {:port=>9600}
[2019-05-23T15:20:36,709][INFO ][logstash.runner ] Logstash shut down.

I couldn't solve the problem. Any help is appreciated.

Best

"host" should be hosts. There is no "protocol" option for the Elasticsearch output.

Thanks for the answer. After configuring my file I get

:exception=>"ArgumentError", :message=>"URI is not valid - host is not specified",

error

Seems like I solved it, thanks

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.