Special characters handling

Hi Folks

I was fixing a bug which came through the upgrade from Spring 2.5 to Spring 3.0.
Now before in Spring 2.5 we had custom method from a repo that extended the ElasticsearchRepository interface, and in the method we passed some parameters which were escaped beforehand.For example
projectId, ElasticMyClass.escape(searchParam), language, dbPageable);

the ElasticMyClass.escape escaped special characters like /? etc. It was working fine.
After the upgrade to Spring 3.0 it startet giving problems each time we tried to search with special character, the i simply removed the ElasticMyClass.escape method, and now it seems to work.My question is ,i know that Spring 2.5 used 7.xx Elastic client, whereas Spring 3 uses Elastic 8 something client.I tried to go through the Release notes to find what did change, but i could find anything, does anybody know what changed and in which version so that escaping is no longer needed ?


Can you please provide more detailed information? It's hard to understand what the issue is with the information you provided.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.