Specify a Reverse proxy endpoint in FileBeat configuration


(RK) #1

Hi,
I am very new to ELK stack. Actually i want to configure Filebeat(Client) in a way that it can directly talk to ElasticSearch present on a WebServer and whose endpoint is exposed through a Reverse proxy.

If i specify the / , it is always trying to hit the port 9200 like :9200/

How can i specify the EleasticSearch(using Reverse proxy mapping) related Configuration in FileBeat.yml file?

Please help.

Thanks and Regards,
RK


(ruflin) #2

you can specify the port by adding yourserver:80 to your host name.


(Andrew Kroh) #3

And you can specify path too if needed. https://www.elastic.co/guide/en/beats/filebeat/current/elasticsearch-output.html#path-option


(system) #4