SQL Server JDBC on Linux box


(anthony-2) #1

Hello - I am trying to get ElasticSearch run on Linux. I got it running on
Windows, where I have some competence, but on Linux I am really struggling.
It is actually running on the Linux box, but no matter what I do to try to
talk to the SQL Server where the data is, I cannot get the app to find the
JDBC diriver. I updated classpath ES_CLASSPATH and moved sqljdbc4 and then
sqljdbc.jar files to the directory /var/lib but that was a no-go as well. I
am running out of ways to try to get ElasticSearch to recognize this JDBC
driver. ANy ideas how to FORCE this to work? I can hit ElasticSearch from
another box on :9200 using Marvel sense, but when I try to populate the
river...BOOM - class not found

  • "error": "NoClassSettingsException[Failed to load class with value
    [jdbc]]; nested: ClassNotFoundException[jdbc]; ",*

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/46771095-0be2-4897-accd-86ab5f2603c7%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #2

put your jdbc jar files in /plugins/river-jdbc dir and it should work.

That said, I think that your river command creation is incorrect but hard to tell without more details.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 2 mai 2014 à 21:29:57, anthony@neo-liberalism.org (anthony@neo-liberalism.org) a écrit:

Hello - I am trying to get ElasticSearch run on Linux. I got it running on Windows, where I have some competence, but on Linux I am really struggling. It is actually running on the Linux box, but no matter what I do to try to talk to the SQL Server where the data is, I cannot get the app to find the JDBC diriver. I updated classpath ES_CLASSPATH and moved sqljdbc4 and then sqljdbc.jar files to the directory /var/lib but that was a no-go as well. I am running out of ways to try to get ElasticSearch to recognize this JDBC driver. ANy ideas how to FORCE this to work? I can hit ElasticSearch from another box on :9200 using Marvel sense, but when I try to populate the river...BOOM - class not found

"error": "NoClassSettingsException[Failed to load class with value [jdbc]]; nested: ClassNotFoundException[jdbc]; ",

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/46771095-0be2-4897-accd-86ab5f2603c7%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.5363f461.613efdc5.2280%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/d/optout.


(anthony-2) #3

Hello - That was a no-go unfortunately...same error after I copied to that
path. I am using same JSON I used to set up river on Windows and it
worked, so I would think the river command is fine. The error specifically
references the jdbc driver. I saw some postings about case sensitivity
when referencing the the driver, but that is not an issue in my
command...case is correct

On Friday, May 2, 2014 12:39:13 PM UTC-7, David Pilato wrote:

put your jdbc jar files in /plugins/river-jdbc dir and it should work.

That said, I think that your river command creation is incorrect but hard
to tell without more details.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 2 mai 2014 à 21:29:57, ant...@neo-liberalism.org <javascript:> (
ant...@neo-liberalism.org <javascript:>) a écrit:

Hello - I am trying to get ElasticSearch run on Linux. I got it running on
Windows, where I have some competence, but on Linux I am really struggling.
It is actually running on the Linux box, but no matter what I do to try to
talk to the SQL Server where the data is, I cannot get the app to find the
JDBC diriver. I updated classpath ES_CLASSPATH and moved sqljdbc4 and then
sqljdbc.jar files to the directory /var/lib but that was a no-go as well. I
am running out of ways to try to get ElasticSearch to recognize this JDBC
driver. ANy ideas how to FORCE this to work? I can hit ElasticSearch from
another box on :9200 using Marvel sense, but when I try to populate the
river...BOOM - class not found

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/496d57dd-73d6-4f87-8ca0-bbb9d624d753%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Jörg Prante) #4

From the single line I can read (Failed to load class with value [jdbc]]),
you did not install the JDBC river correctly, it does not start at all.

If you can give a list of commands you used to install, and the files plus
file attributes in all the directories in Elasticsearch plugins folder, and
a complete log file of the node startup sequence, it would be a lot easier
to help.

Jörg

On Fri, May 2, 2014 at 10:00 PM, anthony@neo-liberalism.org wrote:

Hello - That was a no-go unfortunately...same error after I copied to that
path. I am using same JSON I used to set up river on Windows and it
worked, so I would think the river command is fine. The error specifically
references the jdbc driver. I saw some postings about case sensitivity
when referencing the the driver, but that is not an issue in my
command...case is correct

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoGyRRGX2rASvjSRFMMTbmhGjr7CJyZGG1s58DE2fKYaUw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(anthony-2) #5

OK,I am back with good news. I got things to work on my Ubuntu laptop.
My problem appears to have been related to the original River install. I
was getting errors in the log that I did not notice and then I started
moving JAR files around and made a mess of things. I backed away, deleted
my bad version of the JDBC plugin and reinstalled the correct version for
the version of ElasticSearch I had on the box, then put the JAR files in
the new river-jdbc directory Viola! She worked.
Yahoo!
Thanks,
~aw

On Saturday, May 3, 2014 5:47:08 AM UTC-7, Jörg Prante wrote:

From the single line I can read (Failed to load class with value [jdbc]]),
you did not install the JDBC river correctly, it does not start at all.

If you can give a list of commands you used to install, and the files plus
file attributes in all the directories in Elasticsearch plugins folder, and
a complete log file of the node startup sequence, it would be a lot easier
to help.

Jörg

On Fri, May 2, 2014 at 10:00 PM, <ant...@neo-liberalism.org <javascript:>>wrote:

Hello - That was a no-go unfortunately...same error after I copied to
that path. I am using same JSON I used to set up river on Windows and it
worked, so I would think the river command is fine. The error specifically
references the jdbc driver. I saw some postings about case sensitivity
when referencing the the driver, but that is not an issue in my
command...case is correct

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/77c86853-ea7c-41bc-805b-30d47a247c1c%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #6