SSL rabbitmq input


(Keith Raymond) #1

I have looked and seen different settings but when input any setting dealing with ssl other than ssl => true and verify_ssl => true it states setting unkown. How does logstash know where the certs are if there are no options to input them? In the documentation on the site it says to use ssl_certificate_path and when I use that setting it says that the setting is unknown.


(Magnus Bäck) #2

Which version of the rabbitmq input plugin do you have?


(Keith Raymond) #3

what do you mean input version? Are we talking rabbitmq-server? If so I have 3.7.5 installed. logstash version 2.2.4


(Magnus Bäck) #4

No, I meant the version of your rabbitmq input plugin for Logstash. But if you haven't upgraded that plugin separately you have the one bundled with Logstash 2.2.4. If you consult the Logstash 2.2 documentation you'll see that the rabbitmq plugin doesn't have the certificate options you describe. I suggest you upgrade Logstash. 2.2.4 is really old.


(Keith Raymond) #5

That is what i figured. I will try and find and rpm for 5.0 or 6.0. I will let you know the results shortly.


(Keith Raymond) #6

Ok so I have updated to 6.3 and now I am getting a java exception. I am running java-1.7.0-openjdk. Tried to find a newer version of java but it seems this is the latest version. Any idea on why im getting unsupported major minor version 52.0


(Magnus Bäck) #7

As documented you need Java 8.


(Keith Raymond) #8

I am able to use ssl_certificate_path, but now I cannot connect. I am using a pem file. If I were to use a pkcs file should that file hold the server cert and key or CA cert and key or both?


(Magnus Bäck) #9

I don't know, my SSL-fu isn't strong enough.


(Keith Raymond) #10

I got it to work by adding the cert key and cacert. now on to elasticsearch ssl. Thanks for all your help


(system) #11

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.