Ssl_verification_mode in http_poller input plugin "An exception happened when converging configuration"

I have this configuration file using http_poller input plugin.

input {
  http_poller {
    urls => {
      myurl2 => {
        # Supports all options supported by ruby's Manticore HTTP client
        method => get
        user => "username"
        password => "password"

        url => "https://url_value"
	headers => {
		Accept => "application/json"
		Version => "16.0"

}	

     }
    }
    request_timeout => 60
    # Supports "cron", "every", "at" and "in" schedules by rufus scheduler
    schedule => { cron => "* * * * * UTC"}
    ssl_verification_mode => "none"
  }

}


output {
stdout {
  }
}

When I add

ssl_verification_mode

option in it I am getting error of

[ERROR] 2022-03-29 13:16:42.514 [Agent thread] agent - An exception happened when converging configuration {:exception=>LogStash::Error, :message=>"Don't know how to handle Java::JavaLang::IllegalStateException for PipelineAction::Create<main>"}
[FATAL] 2022-03-29 13:16:42.521 [LogStash::Runner] runner - An unexpected error occurred! {:error=>#<LogStash::Error: Don't know how to handle Java::JavaLang::IllegalStateException for PipelineAction::Create<main>>, :backtrace=>["org/logstash/execution/ConvergeResultExt.java:135:in create'", "org/logstash/execution/ConvergeResultExt.java:60:in add'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:396:in `block in converge_state'"]}

Support for the ssl_verification_mode was added a few weeks ago in plugin version 5.2.0. You can check the installed version using

cd /usr/share/logstash; bin/logstash-plugin list --verbose logstash-input-http_poller

My logstash is up to date and I get 5.1.0 for that.

I have logstash version 8.1.1. Does thsi version have ssl_Verification_mode option in it?

bin/logstash --version
Using bundled JDK: /usr/share/logstash/jdk
logstash 8.1.1

According to the release notes, support was added in 8.1.0.

I thought my logstash was up-to-date but yum was still pointing at the prerelease repo, so I was still on 8.0.0. I just updated it and using ssl_verification_mode no longer produces an exception.

1 Like

Thank You. It is working with 8.1.1

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.