Stats endpoint fails after creating an index

Elasticsearch version 7.6

I have a cluster with 3 master only nodes, 20 data nodes, and one index with 10 shards and 10 replicas. After I create a new index called profiles_v1 with 10 shards and 0 replicas, the stats endpoint begins to fail on every cluster member.

    $ curl localhost:9200/_stats
    {"error":{"root_cause":[{"type":"illegal_argument_exception","reason":"Values less than -1 bytes are not supported: -9223372034551017657b"}],"type":"illegal_argument_exception","reason":"Values less than -1 bytes are not supported: -9223372034551017657b"},"status":400}

When I dropped the new profiles_v1 index, the _stats endpoint on every cluster member began responding successfully. When we re-created the profiles_v1 index, the stats endpoint immediately started to fail with the same error message.

Then we tried dropping the profiles_v1 index and re-creating it under the name profiles_v2. This did not cause the stats endpoint to fail. Dropping profiles_v2 and re-creating it as profiles_v1 was also fine.

I have no idea how a new index has any relation to a negative value being passed along in the stats code.

I did see Node Stats API Failing - "Values less than -1 bytes are not supported: -4b", but free did not report negative values on any of the nodes so I don't think it's related

Can anyone make sense of this?

Hi @tommyzli ,

I would think this is related to #56435, and I seem to remember it being caused by a JDK bug. Upgrading to a newer version should fix it I think.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.