Stopping a cluster to balance shards when restarting a node


(Simon Minery) #1

Hello,

It seems that I cannot make my 1.6 Elasticsearch cluster not reassign shards when restarting a node from the cluster.

When restarting a node, i'm disabled the shard allocation by changing cluster.routing.allocation.enable to none. I'm stopping my node right after, the shards are marked as unassigned and when restarting my node the shards are not automatically re-introduced in the cluster as if my original node did not host them.

I have to enable shard allocation again and the cluster has to rebalance every shards.
Am I supposed to change cluster.routing.allocation.enable to have the desired effect or is this a totally different parameter which is supposed to stop the relocation of the shards ?
Best regards


(Mark Walkom) #2

So this is the process you are following - https://www.elastic.co/guide/en/elasticsearch/reference/1.6/setup-upgrade.html#rolling-upgrades


(system) #3