Stopping a snapshot


(Nate Fox) #1

We do nightly snapshots to S3. They normally take ~2hrs. I have one that
has been running for 4 days now.
I've tried to stop it with this command:
time curl -XDELETE -s
localhost:9200/_snapshot/sim-s3-backup/sim-autobackup_2015-05-15/?pretty

However, even that command hangs. So I let it run for a while, here's the
full output:
time curl -XDELETE -s
localhost:9200/_snapshot/sim-s3-backup/sim-autobackup_2015-05-15/?pretty
^C

real 1544m19.284s
user 0m0.508s
sys 0m2.580s

Is there any other way to get this snapshot to stop? For reference, this is
the output of the status:
curl -XGET -s
localhost:9200/_snapshot/sim-s3-backup/sim-autobackup_2015-05-15/?pretty

{
"snapshots" : [ {
"snapshot" : "sim-autobackup_2015-05-15",
"indices" : [ "7199", "7399", "7299", "7499", "7599", "6202085",
"6202082", "6202083", "8099", "6202059", "6202055", "5099", "5299", "5199",
"6202076", "6202075", "6202078", "6202077", "6202079", "5899", "6202071",
"6202073", "5699", "40061", "40064", "40065", "5599", "6201572", "3001",
"3002", "3008", "3007", "3006", "3005", "5999", "6202044", "6202018",
"6202013", "10109", "10009", "6099", "70005", "6201266", "6199", "6299",
"10309", "10409", "10609", "10509", "7099", "6799", "6899", "40054",
"40057", "40055", "40056", "6202068", "6202067", "6202060", "6699" ],
"state" : "IN_PROGRESS",
"start_time" : "2015-05-16T09:30:06.303Z",
"start_time_in_millis" : 1431768606303,
"failures" : [ ],
"shards" : {
"total" : 0,
"failed" : 0,
"successful" : 0
}
} ]
}

I just want to stop it somehow. I can then delete it or re-run a new
snapshot and get today's date on it.

--
Please update your bookmarks! We have moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3533af43-ec99-4960-afbf-16cab0f12d35%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Nate Fox) #2

For anyone in googleland with the same problem, I 'solved' it by restarting
each node one-by-one. No downtime and eventually the snapshot failed.

On Tuesday, May 19, 2015 at 2:32:58 PM UTC-7, Nate Fox wrote:

We do nightly snapshots to S3. They normally take ~2hrs. I have one that
has been running for 4 days now.
I've tried to stop it with this command:
time curl -XDELETE -s
localhost:9200/_snapshot/sim-s3-backup/sim-autobackup_2015-05-15/?pretty

However, even that command hangs. So I let it run for a while, here's the
full output:
time curl -XDELETE -s
localhost:9200/_snapshot/sim-s3-backup/sim-autobackup_2015-05-15/?pretty
^C

real 1544m19.284s
user 0m0.508s
sys 0m2.580s

Is there any other way to get this snapshot to stop? For reference, this
is the output of the status:
curl -XGET -s
localhost:9200/_snapshot/sim-s3-backup/sim-autobackup_2015-05-15/?pretty

{
"snapshots" : [ {
"snapshot" : "sim-autobackup_2015-05-15",
"indices" : [ "7199", "7399", "7299", "7499", "7599", "6202085",
"6202082", "6202083", "8099", "6202059", "6202055", "5099", "5299", "5199",
"6202076", "6202075", "6202078", "6202077", "6202079", "5899", "6202071",
"6202073", "5699", "40061", "40064", "40065", "5599", "6201572", "3001",
"3002", "3008", "3007", "3006", "3005", "5999", "6202044", "6202018",
"6202013", "10109", "10009", "6099", "70005", "6201266", "6199", "6299",
"10309", "10409", "10609", "10509", "7099", "6799", "6899", "40054",
"40057", "40055", "40056", "6202068", "6202067", "6202060", "6699" ],
"state" : "IN_PROGRESS",
"start_time" : "2015-05-16T09:30:06.303Z",
"start_time_in_millis" : 1431768606303,
"failures" : [ ],
"shards" : {
"total" : 0,
"failed" : 0,
"successful" : 0
}
} ]
}

I just want to stop it somehow. I can then delete it or re-run a new
snapshot and get today's date on it.

--
Please update your bookmarks! We have moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/9300cd81-9be1-40a3-b711-a89e5fc64132%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #3