Stopping elasticsearch service causing app crash


(Pavol Hocko) #1

Hi.. I have a problem when I am stopping ES service. I install service with "elsticsearch-service.bat install". When I stop this service in Task Manager its seems to be stooped but after while I get error. There is nothing in ES logs. It looks like it was sopped correctly but what about this error? ... It is basically same problem as described here. https://discuss.elastic.co/t/jvm-dll-crashes-when-stopping-elastic-search-service/83316 .

But I am using Windows Server 2008 SP2. I tried this with jre1.8.0_181 and jre1.8.0_181. I also tried elasticsearch-oss-6.3.2 and elasticsearch-oss-6.5.0. Still same result. Thank you for your help!

ESerror

Problem signature:
Problem Event Name: APPCRASH
Application Name: elasticsearch-service-x64.exe
Application Version: 1.0.15.0
Application Timestamp: 51543b9d
Fault Module Name: jvm.dll
Fault Module Version: 8.0.1810.13
Fault Module Timestamp: 5b40aa65
Exception Code: c0000005
Exception Offset: 0000000000217a98
OS Version: 6.0.6002.2.2.0.274.10
Locale ID: 1051
Additional Information 1: 86d0
Additional Information 2: dffa1ca9c0e3c740447e8dc6b6ec3d74
Additional Information 3: ea4f
Additional Information 4: 4563587a84ab7f93fbf2b2b80bfd4ed9

Read our privacy statement:
http://go.microsoft.com/fwlink/?linkid=50163&clcid=0x0409