StringIndexOutOfBoundsException: String index out of range: -1


(subin) #1

I run ES v 0.90.0. I'm facing 'StringIndexOutOfBoundsException: String
index out of range: -1 ' only when sending log from a particular server
through logstash to ES.
Below is a sample log from that server:

06-Sep-2013 06:10:45.934 transfer of 'domain.ca/IN' from 10.0.4.83#53:
failed while receiving responses: SERVFAIL

The complete error stack is here: https://gist.github.com/anonymous/6462292
My ES template: https://gist.github.com/anonymous/6462299

Any help would be highly appreciated.

Thanks,

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Martijn Van Groningen) #2

This is a known bug in 0.90.0 which has been fixed:

If you upgrade (I recommend the latests version 0.90.3) this error
shouldn't occur any more.

On 6 September 2013 12:51, subin ksubins321@gmail.com wrote:

I run ES v 0.90.0. I'm facing 'StringIndexOutOfBoundsException: String
index out of range: -1 ' only when sending log from a particular server
through logstash to ES.
Below is a sample log from that server:

06-Sep-2013 06:10:45.934 transfer of 'domain.ca/IN' from 10.0.4.83#53:
failed while receiving responses: SERVFAIL

The complete error stack is here:
https://gist.github.com/anonymous/6462292
My ES template: https://gist.github.com/anonymous/6462299

Any help would be highly appreciated.

Thanks,

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
Met vriendelijke groet,

Martijn van Groningen

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(subin) #3

I've upgraded and ithas got fixed.

Thanks a lot.

On Friday 06 September 2013 05:01 PM, Martijn v Groningen wrote:

This is a known bug in 0.90.0 which has been fixed:
https://github.com/elasticsearch/elasticsearch/issues/2953

If you upgrade (I recommend the latests version 0.90.3) this error
shouldn't occur any more.

On 6 September 2013 12:51, subin <ksubins321@gmail.com
mailto:ksubins321@gmail.com> wrote:

I run ES v 0.90.0. I'm facing 'StringIndexOutOfBoundsException:
String index out of range: -1 ' only when sending log from a
particular server through logstash to ES.
Below is a sample log from that server:

06-Sep-2013 06:10:45.934 transfer of 'domain.ca/IN
<http://domain.ca/IN>' from 10.0.4.83#53: failed while receiving
responses: SERVFAIL

The complete error stack is here:
https://gist.github.com/anonymous/6462292
My ES template: https://gist.github.com/anonymous/6462299

Any help would be highly appreciated.

Thanks,
-- 
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearch+unsubscribe@googlegroups.com
<mailto:elasticsearch%2Bunsubscribe@googlegroups.com>.
For more options, visit https://groups.google.com/groups/opt_out.

--
Met vriendelijke groet,

Martijn van Groningen

You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/iRKLe38hxys/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
Subin

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #4