Subfield not showing on the left side field after 7.16 upgrade

When Upgrading to 7.16.1 from 7.15.2
The subfields from kubernetes object cannot show and analyze.

But it can still searchable.

Anyone can tell me how can I do to enable subfield parsing on left field for new version ?

1 Like

Hi Isaac,

I'm not able to recreate the issue, but maybe I need more information. Are you using a custom index mapping or one created by beats? Can you share the mapping of your index?

Oh, I think I figured out what is happening. Can you go into Stack Management - Advanced Settings and see if turning off discover:searchFieldsFromSource fixes the issue for you?

this is the case since 7.13. and it says this will be deprecated. is it really? because current view from source is very useful.

HI Sachin,

Some changes were required to support Runtime fields in Elasticsearch. But we always welcome constructive criticism. Would you mind opening an issue in the Kibana repository explaining in detail some of the concerns you have with the new format?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.