Switch to Official 5.1.1 Docker Image Node Lock


(Steven Mc Cord) #1

I switched from elasticsearch:5.1.1 to the new official docker image and when I run this on a previously mounted data drive I get the following when starting it up. I noticed that it has my cluster name in the data path whereas the old version did not. In my development environment it can startup just fine without any data and it doesn't include the data path. The error is below. Any thoughts would be helpful. Thanks!

[2017-06-01T14:38:27,540][WARN ][o.e.b.ElasticsearchUncaughtExceptionHandler] [eazy-e-0] uncaught exception in thread [main]
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalStateException: failed to obtain node locks, tried [[/usr/share/elasticsearch/data/icx-es-data]] with lock id [0]; maybe these locations are not writable or multiple nodes were started without increasing [node.max_local_storage_nodes] (was [1])?


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.