Template - settings max_result_window (doesn't affect new index)


(yaara) #1

Hi,
I've created a template
PUT /_template/logstash
{
"index_patterns" : ["logstash*"],
"settings": {
"max_result_window": 500000
},
"mappings": { ....}
}

but the max_result_window on new indexes is still 10,000. when I update the index mapping it works, but I need it to be automatic.

(im using ES 5.6.7)

does anyone have an idea?


(David Pilato) #2

May be another template?
Or your index name does not start with logstash?


(yaara) #3

this is the only template, the index created daily by the exact mapping so I'm pretty sure the template is applied. only this settings from some reason doesn't...

I run GET /_template/
got:

{
"logstash": {
"order": 0,
"template": "[logstash-*]",
"settings": {
"index": {
"max_result_window": "500000"
}
},
"mappings": {... },
"aliases": {}
}
}


(David Pilato) #4

Can you reproduce from scratch with a new cluster?


(yaara) #6

still the same :frowning:


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.