Term is not working after some time


(nkk) #1

Hello,

i am using elasticsearch 1.7, i have a mapping
"testClass": { "type": "string" , "index": "not_analyzed", "norms": { "enabled": false }}
after posting mapping, i could run both match and term queries.
but after 3 to 4 days term start fail, but match works.

queries:

{ "query" : { "match" :{"testClass" : "abcd" }} }

{ "query" : { "term" :{"testClass" : "abcd" }} }

i did not understand this behavior , please help me to under stand, my expectation always term should work.


(David Pilato) #2

What did you index?

Reproduction script?

And you really need to update your version!


(nkk) #3

i have a 15 columns along with testclass, will get data from a upstream and same i am posting.
yes, we have a target in pipe line to upgrade , but for now , we have to go with old version.


(David Pilato) #4

Could you provide a full recreation script as described in

It will help to better understand what you are doing.
Please, try to keep the example as simple as possible.


(nkk) #5

please find the following mapping

{
"settings": {
"index": { "number_of_shards": 5, "number_of_replicas": 2 },
"index.mapper.dynamic": true,
"index.cache.query.enable": true,
"index.store.type": "niofs"
},
"vals": {
"properties": {
"mid": { "type": "string" , "index": "not_analyzed", "norms": { "enabled": false }},
"pub": { "type": "string" , "index": "not_analyzed", "norms": { "enabled": false }},
"sName": { "type": "string" , "index": "not_analyzed", "norms": { "enabled": false }},
"source": { "type": "string" , "index": "not_analyzed", "norms": { "enabled": false }},
"value": { "type": "string" , "index": "not_analyzed", "norms": { "enabled": false }},
"valueType": { "type": "string" , "index": "not_analyzed", "norms": { "enabled": false }},
"whId": { "type": "string" , "index": "not_analyzed", "norms": { "enabled": false }},
"lastUpdated": { "type": "date" , "format": "yyyy-MM-dd"},
"eId": { "type": "long" , "index": "not_analyzed", "norms": { "enabled": false }},
"cList": { "type": "string" , "index": "not_analyzed", "norms": { "enabled": false }},
"eCode": { "type": "string" , "index": "not_analyzed", "norms": { "enabled": false }},
"eLabel": { "type": "string" , "index": "not_analyzed", "norms": { "enabled": false }},
"lblcode": { "type": "string" , "index": "not_analyzed", "norms": { "enabled": false }},
"peCode": { "type": "string" , "index": "not_analyzed", "norms": { "enabled": false }},
"region": { "type": "string" , "index": "not_analyzed", "norms": { "enabled": false }},
"metId": { "type": "long" , "index": "not_analyzed", "norms": { "enabled": false }},
"abbreviation": { "type": "string" , "index": "not_analyzed", "norms": { "enabled": false }},
"testClass": { "type": "string" , "index": "not_analyzed", "norms": { "enabled": false }},
"definition": { "type": "string" , "index": "not_analyzed", "norms": { "enabled": false }},
"med":{ "type": "string" , "index": "not_analyzed", "norms": { "enabled": false }},
"metLabel": { "type": "string" , "index": "not_analyzed", "norms": { "enabled": false }},
"pcity": { "type": "string" , "index": "not_analyzed", "norms": { "enabled": false }},
"unit": { "type": "string" , "index": "not_analyzed", "norms": { "enabled": false }},
"unitType": { "type": "string" , "index": "not_analyzed", "norms": { "enabled": false }},
"uf": { "type": "string" , "index": "not_analyzed", "norms": { "enabled": false }},
"year": { "type": "long" , "index": "not_analyzed", "norms": { "enabled": false }},
"endDate": { "type": "date" , "format": "yyyy-MM-dd"},
"startDate": { "type": "date" , "format": "yyyy-MM-dd"},
"pd": { "type": "string", "index": "not_analyzed", "norms": { "enabled": false }},
"pId": { "type": "string", "index": "not_analyzed", "norms": { "enabled": false }},
"pf" : { "type": "string" , "index": "not_analyzed", "norms": { "enabled": false }},
}
}
}


(David Pilato) #6

How can I play it?


(nkk) #7

Hello,

i have one more similar mapping which has less col and also giving some sample data

please find the following mapping and sample data

{
"settings": {
"index": { "number_of_shards": 5, "number_of_replicas": 2 },
"index.mapper.dynamic": true,
"index.cache.query.enable": true,
"index.store.type": "niofs"
},
"testC": {
"properties": {
"eId": { "type": "long" , "index": "not_analyzed", "norms": { "enabled": false }},
"cList": { "type": "string" , "index": "not_analyzed", "norms": { "enabled": false }},
"eCode": { "type": "string" , "index": "not_analyzed", "norms": { "enabled": false }},
"eLabel": { "type": "string" , "index": "not_analyzed", "norms": { "enabled": false }},
"market": { "type": "string" , "index": "not_analyzed", "norms": { "enabled": false }},
"peode": { "type": "string" , "index": "not_analyzed", "norms": { "enabled": false }},
"region": { "type": "string" , "index": "not_analyzed", "norms": { "enabled": false }},
"dLabel" : { "type": "string" , "index": "not_analyzed", "norms": { "enabled": false }}
}
}
}

Sample data :

{
"eId": 4,
"eLabel": "acd",
"peCode": "A1",
"eCode": "XRR",
"region": "R1",
"cList": "E1 Area",
"market": "F1",
"dLabel": "Ctry#E|B#30y"

}

{
"eId": 9,
"eLabel": "cd2",
"peCode": "C4",
"eCode": "ZRR",
"region": "R1",
"cList": "E1 Area",
"market": "D1",
"dLabel": "Ctry#D|N#31y"
}


(nkk) #8

can some help me on this, not able understand term and match working at same time and after some time only match working , term failing .


(system) #9

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.