Term suggester option for increased word length


(kevins) #1

I am using the Term Suggester found here:
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/search-suggesters-term.html

When send the text of "yo" for term suggest I expect to receive "young" in
the returned options. It is a high frequency word in the data. However, I
need to send 4 letters in order to make it to appear.

Question is how do I get longer word suggests returned when only typing
two letters?

I have set the following options for my term argument:

'min_word_len' => 2,
'size' => $size,
'sort' => 'frequency',
'prefix_len' => 2,
'field' => 'title'

Here are my results.

text of "yo" results:

options":[{"text":"you","score":0.5,"freq":10}]}]}"

text of "you" results:

options":[{"text":"your","score":0.6666666,"freq":2}]}]}"

text of "youn" results:

options":[{"text":"young","score":0.75,"freq":33},{"text":"your","score":0.75,"freq":13},{"text":"you","score":0.6666666,"freq":10}]}]}"

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #2