Terms and anaylaizers

I am trying to do some simple matching on some of the documents in the ES
things like

{"sort":[{"timerange":"desc"}],"from":0,"size":60,"filter":{"and":[{"range":{"timerange":{"from":22688415,"to":22688475}},"term":{"group_id":1234},
"terms" : {"category" : ['people', 'books', 'pictures']}}],"_cache":true}}

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

I have no idea why i forgot to add some more information to this. the query
does not like to work when i have the term and terms applied to it i am
sure it has something to do with the anazer but not really sure.

On Tue, Feb 19, 2013 at 9:07 PM, Wojons Tech wojonstech@gmail.com wrote:

I am trying to do some simple matching on some of the documents in the ES
things like

{"sort":[{"timerange":"desc"}],"from":0,"size":60,"filter":{"and":[{"range":{"timerange":{"from":22688415,"to":22688475}},"term":{"group_id":1234},
"terms" : {"category" : ['people', 'books', 'pictures']}}],"_cache":true}}

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
Enjoy,
Alexis Okuwa
WojonsTech
424.835.1223

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Please describe your mapping and a document supposed to match.

BTW, when having analyzer issues, use the Analyze API: http://www.elasticsearch.org/guide/reference/api/admin-indices-analyze.html

It will help you to understand what is stored in the inverted index.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 20 févr. 2013 à 06:30, Wojons Tech wojonstech@gmail.com a écrit :

I have no idea why i forgot to add some more information to this. the query does not like to work when i have the term and terms applied to it i am sure it has something to do with the anazer but not really sure.

On Tue, Feb 19, 2013 at 9:07 PM, Wojons Tech wojonstech@gmail.com wrote:

I am trying to do some simple matching on some of the documents in the ES things like

{"sort":[{"timerange":"desc"}],"from":0,"size":60,"filter":{"and":[{"range":{"timerange":{"from":22688415,"to":22688475}},"term":{"group_id":1234}, "terms" : {"category" : ['people', 'books', 'pictures']}}],"_cache":true}}

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
Enjoy,
Alexis Okuwa
WojonsTech
424.835.1223

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

I can see that category is setup wrong, i did no set it to not anayalized,
but the group_id is set to long so that does not make sense does it also
need to be set to index yes

On Tue, Feb 19, 2013 at 11:50 PM, David Pilato david@pilato.fr wrote:

Please describe your mapping and a document supposed to match.

BTW, when having analyzer issues, use the Analyze API:
http://www.elasticsearch.org/guide/reference/api/admin-indices-analyze.html

It will help you to understand what is stored in the inverted index.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 20 févr. 2013 à 06:30, Wojons Tech wojonstech@gmail.com a écrit :

I have no idea why i forgot to add some more information to this. the
query does not like to work when i have the term and terms applied to it i
am sure it has something to do with the anazer but not really sure.

On Tue, Feb 19, 2013 at 9:07 PM, Wojons Tech wojonstech@gmail.com wrote:

I am trying to do some simple matching on some of the documents in the ES
things like

{"sort":[{"timerange":"desc"}],"from":0,"size":60,"filter":{"and":[{"range":{"timerange":{"from":22688415,"to":22688475}},"term":{"group_id":1234},
"terms" : {"category" : ['people', 'books', 'pictures']}}],"_cache":true}}

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
Enjoy,
Alexis Okuwa
WojonsTech
424.835.1223

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
Enjoy,
Alexis Okuwa
WojonsTech
424.835.1223

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.