The "is between" & "is not between" operator function not showing up


(Steven) #1

Hi,

We are running Kibana 5.5 and i see the "is between" & "is not between" operators show up on some of my services, but not all. Why is that?

Thank you in advance.


(Tim Roes) #2

Hi Steven,

which filters are available depend on the type of the field.
Most likely you have selected a text/keyword field and thus don't see those two filters. If you try selecting a numeric field or e.g. an ip field, you should see those filters.

Cheers,
Tim


(Steven) #3

Hi Tim,

Thanks for the quick reply. I will change it to a number field.

Another question, in some cases i am also seeing that the "visualize" button does not show up underneath on some fields i've extracted. Could you help me understand why?

Thanks again.


(Tim Roes) #4

Hi,

the most likely reason why a field is not "visualizable" from the Discover app is the following:

It is a field of type text (this means an analyzed string), Elasticsearch cannot aggregate on those by default. In this case you might still have the same field also in an unanalyzed version (most often with the suffix .keyword or .raw but the same name). You can just go to the visualize app and do a terms aggregation on that unanalyzed field in this case (but Discover won't show you the button).

Cheers,
Tim


(Tim Roes) #5

I've tried to explain the effect of analyzing on strings and thus the search, in this tutorial. And since Elasticsearch version 5 analyzed strings are not aggregatable by default anymore, though you could enable it.


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.