The publish_address {1.2.3.4:9300} is not the real ip address


(JiGe) #1

[2019-03-20T19:01:58,144][INFO ][o.e.t.TransportService ] [node-12] publish_address {1.2.3.4:9300}, bound_addresses {[::]:9300}
[node-12] zen-disco-elected-as-master ([0] nodes joined), reason: new_master {node-12}{hsumJuklSeiML7vrawgGQw}{opENN3J4T-afQmnvHJtX5Q}{1.2.3.4}{1.2.3.4:9300}
The Address of the es node is 10.10.192.12. But the publish_address is 1.2.3.4.
Why was this happened?


(David Pilato) #2

What is your elasticsearch.yml file?


(JiGe) #3

cluster.name: jxq-srv
node.name: node-12
network.host: 0.0.0.0
discovery.zen.ping.unicast.hosts: ["10.10.192.12:9300"]
xpack.security.transport.ssl.enabled: true


(David Turner) #4

I would guess that you have multiple interfaces on this machine, and Elasticsearch is picking the wrong one. If you want it to bind to 10.10.192.12 then set network.host: 10.10.192.12.


(JiGe) #5

It works!!!!
Thanks very much!


(system) closed #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.