The search API is expecting the max_concurrent_shard_requests parameter

I'm using the bitnami/elasticsearch:6.5.15 image and connecting to it via the Magento 2 framework. When making a search request I am presented with the error:

maxConcurrentShardRequests must be >= 1

I have a single Elasticsearch docker container running and my understanding is that I could just add the param max_concurrent_shard_request=1, but, my understanding is that Elastic Search sets a default value. Is that not true? If not, can I set a default value?

First, I do not know, if that non-official docker image is doing anything special, that might be something to ask the bitnami folks.

Second, I do however think that the name issue seems to be something in your stack setting that shard size to a value smaller than 1 (this is what the code is checking for when that exception is thrown).

Maybe there is a piece of code overwriting your configuration after you set it?


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.