Ther is no output being shown on the command prompt even after clearing .sincedb file

configuration file:
input {
file {

 type => "apache-access" 
start_position=> "beginning"


output {
stdout {



after running the logstash this is showig on the command prompt
E:\kibana\logstash-7.1.1\logstash-7.1.1>bin\logstash -f E:\kibana\logstash-7.1.1\logstash-7.1.1\config\pipeline.conf --config.reload.automatic
Java HotSpot(TM) 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.jruby.runtime.encoding.EncodingService (file:/E:/kibana/logstash-7.1.1/logstash-7.1.1/logstash-core/lib/jars/jruby-complete- to field
WARNING: Please consider reporting this to the maintainers of org.jruby.runtime.encoding.EncodingService
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
Sending Logstash logs to E:/kibana/logstash-7.1.1/logstash-7.1.1/logs which is now configured via
[2019-06-13T15:45:30,346][WARN ][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified
[2019-06-13T15:45:30,367][INFO ][logstash.runner ] Starting Logstash {"logstash.version"=>"7.1.1"}
[2019-06-13T15:45:33,523][INFO ][logstash.javapipeline ] Starting pipeline {:pipeline_id=>"main", "pipeline.workers"=>4, "pipeline.batch.size"=>125, "pipeline.batch.delay"=>50, "pipeline.max_inflight"=>500, :thread=>"#<Thread:0x3b58a503 run>"}
[2019-06-13T15:45:34,761][INFO ][logstash.inputs.file ] No sincedb_path set, generating one based on the "path" setting {:sincedb_path=>"E:/kibana/logstash-7.1.1/logstash-7.1.1/data/plugins/inputs/file/.sincedb_0a875bbe5a2659163ba803e0c598bcbc", :path=>["\E:\kibana\logstash-7.1.1\logstash-7.1.1\data\event-data\apache_access.log"]}
[2019-06-13T15:45:34,812][INFO ][logstash.javapipeline ] Pipeline started {""=>"main"}
[2019-06-13T15:45:34,882][INFO ][logstash.agent ] Pipelines running {:count=>1, :running_pipelines=>[:main], :non_running_pipelines=>}
[2019-06-13T15:45:34,911][INFO ][filewatch.observingtail ] START, creating Discoverer, Watch with file and sincedb collections
[2019-06-13T15:45:35,297][INFO ][logstash.agent ] Successfully started Logstash API endpoint {:port=>9600}
(there is no incoming output)

Hi deepanshu,

Please format code with the ``` notations, as mentioned in the guidelines or using the editor window.

Please, can you elaborate. I tried using that but was not able to implement it.

Use forward slash, not backslash, in the path option of a file input.

1 Like

For windows the notations should be fine, right?

Should there be a slash before the drive letter E?

Try this as path:


I already tried what you are saying but there is no difference and the problem remains the same .

I had the same problem. Problem is in Windows, you have to use / in path definition, as user Badger have already advised to you.

This conf works for me perfectly:

input {
file {
start_position => "beginning"
sincedb_path => "nul"


output {
elasticsearch {
hosts => ["http://localhost:9200"]
index => "contacts"


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.