Time problem


(Quentin Guiot) #1

hello

I have a little problem with elasticsearch when using it with kibana and
logstash

when i lauch my logstash.conf, i get an error on kibana : "No results There
were no results because no indices were found that match your selected time
span"
i really don't know why
can someone help me with this please

my logstash.conf file is like this :

input {
file {
path => [ "/travail/webseal/XR_-stdout.txt",
"/travail/webseal/XR_-stderr.txt", "/travail/webseal/XR__metrologie.log" ]
type => "logs_webseal"
}
}

output {
elasticsearch {
}
}

thanks

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/65ffd7ef-3e5c-4953-a3fc-245dcfd13af6%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Mark Walkom) #2

Do you have logstash indexes in the elasticsearch cluster?
Also, what's your kibana config look like?

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 13 May 2014 23:55, Quentin Guiot silent.spectr@gmail.com wrote:

hello

I have a little problem with elasticsearch when using it with kibana and
logstash

when i lauch my logstash.conf, i get an error on kibana : "No results There
were no results because no indices were found that match your selected time
span"
i really don't know why
can someone help me with this please

my logstash.conf file is like this :

input {
file {
path => [ "/travail/webseal/XR_-stdout.txt",
"/travail/webseal/XR_-stderr.txt", "/travail/webseal/XR__metrologie.log" ]
type => "logs_webseal"
}
}

output {
elasticsearch {
}
}

thanks

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/65ffd7ef-3e5c-4953-a3fc-245dcfd13af6%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/65ffd7ef-3e5c-4953-a3fc-245dcfd13af6%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624ZOjd4Mwa39BWS00BWVgGdLxotqRtv66jkkGY2dp%3DqwLA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Quentin Guiot) #3

nop, I don't have any logstash indexes or at least i think so ^^'

And I only changed the IP address in my kibana config.js file :
elasticsearch: "http://220.140.xx.xx:9200" with the IP of the elasticsearch
server
the rest of the file is unchanged

I installed the Marvel plug-in and it's working perfectly

Le mardi 13 mai 2014 23:09:56 UTC+2, Mark Walkom a écrit :

Do you have logstash indexes in the elasticsearch cluster?
Also, what's your kibana config look like?

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com <javascript:>
web: www.campaignmonitor.com

On 13 May 2014 23:55, Quentin Guiot <silent...@gmail.com <javascript:>>wrote:

hello

I have a little problem with elasticsearch when using it with kibana and
logstash

when i lauch my logstash.conf, i get an error on kibana : "No results There
were no results because no indices were found that match your selected time
span"
i really don't know why
can someone help me with this please

my logstash.conf file is like this :

input {
file {
path => [ "/travail/webseal/XR_-stdout.txt",
"/travail/webseal/XR_-stderr.txt", "/travail/webseal/XR__metrologie.log" ]
type => "logs_webseal"
}
}

output {
elasticsearch {
}
}

thanks

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/65ffd7ef-3e5c-4953-a3fc-245dcfd13af6%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/65ffd7ef-3e5c-4953-a3fc-245dcfd13af6%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e41ee3e5-2ea0-4d20-9d96-73eec6abc19e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(ElasticSearch Users mailing list) #4

If you don't have logstash style time based indexes, you'll need to open
your dashboard config (gear icon top right), go to to Index tab, change
Timestamping: none, and Default Index: . Click Save, go
back to your dashboard and remove any time filters up on the top (if any).

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/529ff6fb-1aa7-418f-b85d-ade824d7fc6a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Quentin Guiot) #5

hi
thanks for the reply
but when i do what you say, i got another error

Oops! IndexMissingException[[INDEX_NONE] missing]

Le mercredi 14 mai 2014 15:56:30 UTC+2, Binh Ly a écrit :

If you don't have logstash style time based indexes, you'll need to open
your dashboard config (gear icon top right), go to to Index tab, change
Timestamping: none, and Default Index: . Click Save, go
back to your dashboard and remove any time filters up on the top (if any).

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/19c4e475-5944-4de5-a1e5-d14c7117aa97%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Quentin Guiot) #6

ok so i put "_all" in default index and the errors are gone

But now i need to input the three files that are in my "logstash.conf" file
and i really don't know how
i tried a lot of things, checked on google so many times but there are few
tutorials on the net and they didn't help me at all

Maybe someone here could

thanks

Le mercredi 14 mai 2014 16:49:53 UTC+2, Quentin Guiot a écrit :

hi
thanks for the reply
but when i do what you say, i got another error

Oops! IndexMissingException[[INDEX_NONE] missing]

Le mercredi 14 mai 2014 15:56:30 UTC+2, Binh Ly a écrit :

If you don't have logstash style time based indexes, you'll need to open
your dashboard config (gear icon top right), go to to Index tab, change
Timestamping: none, and Default Index: . Click Save, go
back to your dashboard and remove any time filters up on the top (if any).

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/5eee26d1-debf-4b9b-9bc6-36b698e4f280%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Quentin Guiot) #7

Up

someone can help me please ?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f6884469-8285-4c08-b7de-af4f94d6faa8%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Ivan Brusic) #8

Have you tried asking the Logstash mailing list? It does not sound like an
Elasticsearch issue.

--
Ivan

On Mon, May 19, 2014 at 2:22 AM, Quentin Guiot silent.spectr@gmail.comwrote:

Up

someone can help me please ?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/f6884469-8285-4c08-b7de-af4f94d6faa8%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/f6884469-8285-4c08-b7de-af4f94d6faa8%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQB9PyYb2h1h8CZipaHa1tUQK9EtxBaO%3DUhRzJheLs6t-g%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Quentin Guiot) #9

i just posted a message
hope someone answers
thanks

Le lundi 19 mai 2014 23:57:47 UTC+2, Ivan Brusic a écrit :

Have you tried asking the Logstash mailing list? It does not sound like an
Elasticsearch issue.

--
Ivan

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/92ca8e97-02c7-47ba-9bb7-e2f28366c93d%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #10