Today my master node core dumped


(None) #1

Using 1.6.0

# JRE version: Java(TM) SE Runtime Environment (8.0_45-b15) (build 1.8.0_45-b15)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (25.45-b02 mixed mode windows-amd64 compressed oops)
# Problematic frame:
# C  [KERNELBASE.dll+0x1c7f]
#
# Core dump written. Default location: C:\elasticsearch\elasticsearch-1.6.0-master01\hs_err_pid816.mdmp

What info can I provide back or look at?


(Nik Everett) #2

If you are running a supported JVM (and you are) odds are reasonably good its a hardware issue. If possible you should try running a ram test. Beyond that I'm not sure.


(None) #3

Running Oracle JDK on Windows 2008


(Mike Simos) #4

It could be related to this issue:

There was probably more information then what you provided from the dump message.


(None) #5

Ok let me see...


(None) #6

Looks like sigar, walks like sigar, then it must be....

J 6374 org.hyperic.sigar.FileSystemUsage.gather(Lorg/hyperic/sigar/Sigar;Ljava/lang/String;)V (0 bytes) @ 0x000000000207ba63 [0x000000000207ba00+0x63]
J 8045 C2 org.elasticsearch.monitor.fs.SigarFsProbe.stats()Lorg/elasticsearch/monitor/fs/FsStats; (333 bytes) @ 0x0000000002e2c40c [0x0000000002e2bac0+0x94c]
J 8447 C2 org.elasticsearch.marvel.agent.AgentService$ExportingWorker.exportNodeStats()V (124 bytes) @ 0x0000000002edddd8 [0x0000000002edbfc0+0x1e18]
J 11910% C2 org.elasticsearch.marvel.agent.AgentService$ExportingWorker.run()V (253 bytes) @ 0x00000000038ccc50 [0x00000000038cc740+0x510]
j java.lang.Thread.run()V+11

I guess I can disable sigar :smile:


(system) #7