Transfer json pattern capture filter configuration to yaml format, regex pattern not work?


(Lord Artois) #1

Hello, wonder anyone here could help

I was transfering this json to a yml format to include in the yml config
file, but the patterns always cause a parse exception.

{
"settings" : {
"analysis" : {
"filter" : {
"code" : {
"type" : "pattern_capture",
"preserve_original" : 1,
"patterns" : [
"(([a-z]+)(\d*))"
]
}
},
"analyzer" : {
"code" : {
"tokenizer" : "pattern",
"filter" : [ "code", "lowercase" ]
}
}
}
}
}

  code:
      type: pattern_capture
      preserve_original: false
      patterns: [/(([a-z]+)(\d*))/]

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3bc3a9c1-de1a-48ab-a026-5cddf303ef5b%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #2

May be you could try to use patterns: "[/(([a-z]+)(\d*))/]"

Not tested though.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 23 janv. 2014 à 15:41, Lord Artois duketristan@gmail.com a écrit :

Hello, wonder anyone here could help

I was transfering this json to a yml format to include in the yml config file, but the patterns always cause a parse exception.
{
"settings" : {
"analysis" : {
"filter" : {
"code" : {
"type" : "pattern_capture",
"preserve_original" : 1,
"patterns" : [
"(([a-z]+)(\d*))"
]
}
},
"analyzer" : {
"code" : {
"tokenizer" : "pattern",
"filter" : [ "code", "lowercase" ]
}
}
}
}
}
code:
type: pattern_capture
preserve_original: false
patterns: [/(([a-z]+)(\d*))/]

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3bc3a9c1-de1a-48ab-a026-5cddf303ef5b%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/5242D449-D3AF-4351-9C11-E4FFF274915D%40pilato.fr.
For more options, visit https://groups.google.com/groups/opt_out.


(Lord Artois) #3

Thank you, it looks like this feature is in version 0.90.3, mine is 0.90.2

On Thursday, January 23, 2014 11:06:16 PM UTC+8, David Pilato wrote:

May be you could try to use patterns: "[/(([a-z]+)(\d*))/]"

Not tested though.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 23 janv. 2014 à 15:41, Lord Artois <duket...@gmail.com <javascript:>>
a écrit :

Hello, wonder anyone here could help

I was transfering this json to a yml format to include in the yml config
file, but the patterns always cause a parse exception.

{
"settings" : {
"analysis" : {
"filter" : {
"code" : {
"type" : "pattern_capture",
"preserve_original" : 1,
"patterns" : [
"(([a-z]+)(\d*))"
]
}
},
"analyzer" : {
"code" : {
"tokenizer" : "pattern",
"filter" : [ "code", "lowercase" ]
}
}
}
}
}

  code:
      type: pattern_capture
      preserve_original: false
      patterns: [/(([a-z]+)(\d*))/]

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/3bc3a9c1-de1a-48ab-a026-5cddf303ef5b%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/4faa1e1e-8bef-4b3b-b87c-24cc93f8786c%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #4