Transport Client Error both on 5.3.2 and 5.4.0


(Sam) #1

I keep getting below error both on 5.3.2 and 5.4.0 when using Java Transport Client.
occasionally i get valid response, trying 3 node cluster in a single machine.

NoNodeAvailableException[None of the configured nodes are available: [{#transport#-1}{PCD5ssO9QrKeqLea1XFsaw}{127.0.0.1}{127.0.0.1:9300}]]
at org.elasticsearch.client.transport.TransportClientNodesService.ensureNodesAreAvailable(TransportClientNodesService.java:348)
at org.elasticsearch.client.transport.TransportClientNodesService.execute(TransportClientNodesService.java:246)
at org.elasticsearch.client.transport.TransportProxyClient.execute(TransportProxyClient.java:59)
at org.elasticsearch.client.transport.TransportClient.doExecute(TransportClient.java:366)
at org.elasticsearch.client.support.AbstractClient.execute(AbstractClient.java:408)
at org.elasticsearch.action.ActionRequestBuilder.execute(ActionRequestBuilder.java:80)
at org.elasticsearch.action.ActionRequestBuilder.execute(ActionRequestBuilder.java:54)


(Mark Walkom) #2

This probably relates to your other thread.


(Sam) #3

I tried all the ports, 9300,9301,9302, still the same, very intermittent.


(Mark Walkom) #4

Are you still restarting things randomly?


(Sam) #5

No I am not restarting now, all 3 nodes are up and running and still see this error. in both 5.3.2 and 5.4.0


(Sam) #6

Found the Issue, the issue is with version of the Transport Client library, i was using 5.0.0 Transport java driver for 5.4.0 ES , however when i changed it to 5.3.2 as mentioned here Option "client.transport.sniff" not working with v5.4.0 Transport Client

Everything works fine , don't see the issue anymore.

Thanks
Sam


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.