Troubles with installation instructions on ubuntu

I'm running a vagrant box which runs ubuntu inside a vm (using Laravel Homestead box)

I'm trying to install the Elastic App-search product.

The first requirement is to install Elastic search, which I have done multiple times. I did the following steps:
https://www.elastic.co/guide/en/elasticsearch/reference/current/deb.html

wget -qO - https://artifacts.elastic.co/GPG-KEY-elasticsearch | sudo apt-key add -
sudo apt-get install apt-transport-https
echo "deb https://artifacts.elastic.co/packages/7.x/apt stable main" | sudo tee -a /etc/apt/sources.list.d/elastic-7.x.list
sudo apt-get update && sudo apt-get install elasticsearch

I'm using the systemd configuration:

sudo /bin/systemctl daemon-reload
sudo /bin/systemctl enable elasticsearch.service

I'm running curl localhost:9200 and everything is working.

Next I try to install elastic app search.
https://www.elastic.co/guide/en/app-search/current/installation.html#installation-self-managed.
Which doesn't have instructions for debian systems. But it does have a .deb install file. I downloaded the file and put it in my project route.

I ran dpkg -i on the file and it seems to have installed. When I run the command to check the file location it shows this:

 dpkg -L enterprise-search
/.
/etc
/etc/init.d
/etc/init.d/enterprise-search
/var
/var/log
/var/log/enterprise-search
/usr
/usr/share
/usr/share/enterprise-search
/usr/share/enterprise-search/README.md
/usr/share/enterprise-search/bin
/usr/share/enterprise-search/bin/vendor
/usr/share/enterprise-search/bin/vendor/filebeat
/usr/share/enterprise-search/bin/vendor/filebeat/filebeat-linux-x86_64
/usr/share/enterprise-search/bin/enterprise-search
/usr/share/enterprise-search/filebeat
/usr/share/enterprise-search/filebeat/ecs-template.json
/usr/share/enterprise-search/filebeat/filebeat-ecs.yml
/usr/share/enterprise-search/lib
/usr/share/enterprise-search/lib/require_java_version.sh
/usr/share/enterprise-search/lib/enterprise-search.war
/usr/share/enterprise-search/jetty
/usr/share/enterprise-search/jetty/webserver-ssl.xml
/usr/share/enterprise-search/jetty/webserver-ssl-with-redirect.xml
/usr/share/enterprise-search/jetty/webserver.xml
/usr/share/enterprise-search/LICENSE
/usr/share/enterprise-search/config
/usr/share/enterprise-search/config/env.sh
/usr/share/enterprise-search/config/enterprise-search.yml
/usr/share/enterprise-search/NOTICE.txt
/usr/share/doc
/usr/share/doc/enterprise-search
/usr/share/doc/enterprise-search/changelog.gz
/usr/lib
/usr/lib/systemd
/usr/lib/systemd/system
/usr/lib/systemd/system/enterprise-search.service

I'm not really sure if this is the correct location? I want it to live in the same place as my elasticsearch install, but I'm actually not sure. I did all the next steps for the install process and ran:
./usr/share/enterprise-search/bin/elasticsearch

But this gives me the error:

Could not find java in PATH

I'm confused by this since the main elasticsearch installation works and that also needs java? Also, I want it also to run with systemd auto-enable and I want it to be available with enterprise-search start/stop. Not sure how to handle that.

Hi @Christophvh, Elasticsearch comes bundled with Java. For Enterprise-search you have to setup Java 8 or 11 according to the documentation, see https://www.elastic.co/guide/en/enterprise-search/current/installation.html#installation-self-managed and configure JAVA_HOME for Enterprise-search.

Hi @fgjensen Thanks for the answer, but that is my question. I have java installed since i have elasticsearch installed, why do i have to install java 2 times?

I have reinstalled java and now it works. Seems absurd to have 2 instances running? But i guess thats normal?

Also i tried:
sudo /bin/systemctl daemon-reload
sudo /bin/systemctl enable enterprise-search.service

sudo /bin/systemctl start enterprise-search.service

But this hogs all memory and keeps crashing. When running:
./bin/enterprise-search it works without problems?

As I understand the documentation Java 8 or 11 is a prerequisite for installing Enterprise Search. So you could have installed Java 11 first, configure JAVA_HOME and used this JDK for both installations. An other option is to configure JAVA_HOME to point to the jdk delivered with Elasticsearch search, since Enterprise Search requires JAVA_HOME to be set. You do not need to install Java twice, but you can e.g. run Elasticsearch with Java 14 and Enterprise Search with Java 11. How much memory does the VM have and how much is reserved for Elasticsearch? When you try to start Enterprise Search as a service what does it write to the journal e.g. sudo journalclt -r -u Enterprisesearch

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.