Trying to apply a wildcard exclusion in the Query bar using Lucene

Hello I am trying filter out the records where the field: "callCodeDesc" does not equal wildcard "NIVR"

in the query bar for Lucene I entered: callCodeDesc: - NIVR
(I have an asterisk before the "N" and after the "R". )

I would appreciate any help on how to complete this in the query bar or in the custom dsl option thanks!

Hi @dleota,

The - should go before the field name: -callCodeDesc:*NIVR*.

However consider using KQL in the query bar instead, it has a more human readable syntax (in this case NOT callCodeDesc:*NIVR*)

If this doesn't work for you the mapping of your index might have to be adjusted, please post the mapping here in this case.

@flash1293 The Lucene syntax worked. I'll also try the KQL syntax. Thank you!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.