Trying to export from OpenTelemetry dotnet to Elastic APM 7.17.7

Kibana version:
7.17.7
Elasticsearch version:
7.17.7
APM Server version:
7.17.7

Hi :slightly_smiling_face:

I'm working on an ASP.NET application with .NET 4.8, which I've instrumented with OpenTelemetry.
Exporting to Jaeger works fine, but I cannot for the life of me export to Elastic APM. We have an Elastic APM instance running on premise.

From what I understand, I should be able to export directly to the APM server without using the OTEL collector?

These are the settings I'm currently using:

If I use GRPC, I get errors when the exporter is trying to send:

If I use HTTP Protobuf with the same URL, I don't get any errors, but the data also doesn't show up anywhere in APM.

In the case of HTTP Protobuf, is there any console or something somewhere in Kibana where I can see why the data isn't showing up in Kibana?

In the case of GRPC, the ops guy has a suspicion it's got something to do with TLS and having to set a certificate (no idea why he thinks that). I've noticed the OTEL collector has settings for cert and key, whereas the AddOtlpExporter method in dotnet does not. Would that mean I'm forced to use the OTEL collector if certificates were the issue? Does a missing TLS certificate in GRPC result in status "Unavailable"?

As a side note, I started an Elastic Cloud trial and tried to export to that instance and it worked immediately.

1 Like

Hi,

did you follow the instructions here?