Trying to install elasticsearch as a service on Centos 6 with cPanel


(Ali Samii) #1

I am trying to install elasticsearch on a cPanel server with the following
specs:

OS: CENTOS 6.5 x86_64
Virtual Machine: virtuoso
WHM Version: 11.44.1 (build 18)

I have used yum to install elasticsearch using the install guide provided
here:

The server is running fine when trying to access it as root from the
command line:

root@cyrus [/]# curl localhost:9200/_nodes/process?pretty
{
"cluster_name" : "elasticsearch",
"nodes" : {
"KIgDLFv-QzSuJpjEM3vC1w" : {
"name" : "Sean Garrison",
"transport_address" : "inet[/192.232.253.214:9300]",
"host" : "cyrus.trilionltd.com",
"ip" : "192.232.253.212",
"version" : "1.3.2",
"build" : "dee175d",
"http_address" : "inet[/192.232.253.214:9200]",
"process" : {
"refresh_interval_in_millis" : 1000,
"id" : 27618,
"max_file_descriptors" : 65535,
"mlockall" : false
}
}
}
}
root@cyrus [/]#

However, when I try to use elastic search from one of the cPanel users, it
fails:

nrfiorg@cyrus
➜ curl http://localhost:9200/_nodes/process?pretty
zsh: no matches found: http://localhost:9200/_nodes/process?pretty
nrfiorg@cyrus

What I am trying to do is install elasticsearch server-wide and make it
available as a service for all accounts (cPanel users) on the machine.
However, naturally, each site will have their own index of files and
documents which will be accessible within the elasticsearch instance.

What am I doing wrong, and how do I resolve this?

Thank you.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ed8fa2d0-7c06-4560-8e67-685cbc6896c7%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Jörg Prante) #2

This is not an ES issue. As said on IRC, because of shell interpretation of
? or *, you should always use quotes around curl requests, like this

curl 'http://localhost:9200/_nodes/process?pretty'

Jörg

On Tue, Sep 9, 2014 at 2:17 PM, Ali Samii aalisamii@gmail.com wrote:

I am trying to install elasticsearch on a cPanel server with the following
specs:

OS: CENTOS 6.5 x86_64
Virtual Machine: virtuoso
WHM Version: 11.44.1 (build 18)

I have used yum to install elasticsearch using the install guide provided
here:

http://tecadmin.net/install-elasticsearch-on-linux/

The server is running fine when trying to access it as root from the
command line:

root@cyrus [/]# curl localhost:9200/_nodes/process?pretty
{
"cluster_name" : "elasticsearch",
"nodes" : {
"KIgDLFv-QzSuJpjEM3vC1w" : {
"name" : "Sean Garrison",
"transport_address" : "inet[/192.232.253.214:9300]",
"host" : "cyrus.trilionltd.com",
"ip" : "192.232.253.212",
"version" : "1.3.2",
"build" : "dee175d",
"http_address" : "inet[/192.232.253.214:9200]",
"process" : {
"refresh_interval_in_millis" : 1000,
"id" : 27618,
"max_file_descriptors" : 65535,
"mlockall" : false
}
}
}
}
root@cyrus [/]#

However, when I try to use elastic search from one of the cPanel users, it
fails:

nrfiorg@cyrus
➜ curl http://localhost:9200/_nodes/process?pretty
zsh: no matches found: http://localhost:9200/_nodes/process?pretty
nrfiorg@cyrus

What I am trying to do is install elasticsearch server-wide and make it
available as a service for all accounts (cPanel users) on the machine.
However, naturally, each site will have their own index of files and
documents which will be accessible within the elasticsearch instance.

What am I doing wrong, and how do I resolve this?

Thank you.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/ed8fa2d0-7c06-4560-8e67-685cbc6896c7%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/ed8fa2d0-7c06-4560-8e67-685cbc6896c7%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoHkSobk%2BB_Qx-xHfKnXUWQU8Wget2Wumk%2BRKRbLGEEgvw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #3