Trying to install elasticsearch on ubuntu 12; running into JAVA_HOME problems


(David Edelhart) #1

I am having stupid NooB problems with elasticsearch getting it going on
ubuntu

I have followed https://gist.github.com/2026107 (s/19.0/19.9) and installed
JDK 7, and setup JAVA_HOME

however it is compaining when I try to start the service, "no JDK found -
please set JAVA_HOME"

yet both echo $JAVA_HOME and sudo echo $JAVA_HOME give me "/usr/bin/java"

Any suggestions?

--


(Robin Verlangen) #2

As far as I'm aware of the application appens "/bin/java" to the JAVA_HOME
path. So try setting this:

export JAVA_HOME=/usr

Best regards,

Robin Verlangen
Software engineer
*
*
W http://www.robinverlangen.nl
E robin@us2.nl

Disclaimer: The information contained in this message and attachments is
intended solely for the attention and use of the named addressee and may be
confidential. If you are not the intended recipient, you are reminded that
the information remains the property of the sender. You must not use,
disclose, distribute, copy, print or rely on this e-mail. If you have
received this message in error, please contact the sender immediately and
irrevocably delete this message and any copies.

2012/9/20 David Edelhart poppin.fressh@gmail.com

I am having stupid NooB problems with elasticsearch getting it going on
ubuntu

I have followed https://gist.github.com/2026107 (s/19.0/19.9) and
installed JDK 7, and setup JAVA_HOME

however it is compaining when I try to start the service, "no JDK found -
please set JAVA_HOME"

yet both echo $JAVA_HOME and sudo echo $JAVA_HOME give me "/usr/bin/java"

Any suggestions?

--

--


(Derry O' Sullivan) #3

Sometimes on ubuntu, you can run the update alternatives command to pick
the main java executable referenced by the OS:
https://help.ubuntu.com/community/Java

I would suspect that it's still pointing to some alternative Java version
that is not compatible...

On Thursday, 20 September 2012 19:45:11 UTC+1, Robin Verlangen wrote:

As far as I'm aware of the application appens "/bin/java" to the JAVA_HOME
path. So try setting this:

export JAVA_HOME=/usr

Best regards,

Robin Verlangen
Software engineer
*
*
W http://www.robinverlangen.nl
E ro...@us2.nl <javascript:>

Disclaimer: The information contained in this message and attachments is
intended solely for the attention and use of the named addressee and may be
confidential. If you are not the intended recipient, you are reminded that
the information remains the property of the sender. You must not use,
disclose, distribute, copy, print or rely on this e-mail. If you have
received this message in error, please contact the sender immediately and
irrevocably delete this message and any copies.

2012/9/20 David Edelhart <poppin...@gmail.com <javascript:>>

I am having stupid NooB problems with elasticsearch getting it going on
ubuntu

I have followed https://gist.github.com/2026107 (s/19.0/19.9) and
installed JDK 7, and setup JAVA_HOME

however it is compaining when I try to start the service, "no JDK found -
please set JAVA_HOME"

yet both echo $JAVA_HOME and sudo echo $JAVA_HOME give me "/usr/bin/java"

Any suggestions?

--

--


(system) #4